1

Any ideas on how to address this issue with the geowebcache?

< geowebcache-cache-result: MISS
< geowebcache-miss-reason: request does not align to grid(s) 'EPSG:4326' 

I also tried other projections but the same output.

< geowebcache-cache-result: MISS
< geowebcache-miss-reason: request does not align to grid(s) 'EPSG:900913' 

The tiles are generated in the appropriate directories so I assume path issues might not be the problem. Direct wms integration is enabled. The documentation mentions tiles size might be the issue but width and height is 256 and is consistent with the gridset dimensions. (http://docs.geoserver.org/stable/en/user/geowebcache/troubleshooting.html#direct-wms-integration) as for the BBOX size, I am using the dimension derived from the GWC seed form.

Any ideas on how to approach this issue?

How can I make sure that the GeoServer is actually serving the cached data?

1

It means you are asking for tiles that do not line up with the grid. Check your extent matches the grid extent.

  • I am using the bounds as calculated by the layer bounds. Is there a way to get the valid bounds in geoserver? – Koen Feb 11 '17 at 19:53
  • Look in the capabilities doc – Ian Turton Feb 11 '17 at 19:58
  • 1
    You need to use the gridset bounds, not the layer one. – Andrea Aime Feb 13 '17 at 9:06
0

When you create the layer, on the Data tab, under the Bounding Boxes heading, you have two options for automatically creating the bounding boxes: 'Compute from data', and 'Compute from SRS bounds'. You want 'Compute from SRS bounds'.

If you do that, everything will work correctly after that.

Hope that helps someone. I spent like 2 weeks on this.

Aaron

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.