8

I am a new QGIS user, have installed QGIS on a Mac running Snow Leopard OSX 10.6.8 following all the instructions. QGIS seems to work well for everything other than when I boot up I get the message "Unable to load the plugin: Unable to load required package rpy2. Please ensure that both R, and the corresponding version of Rpy2 are correctly installed".

I have installed Rpy2 several times and reloaded R. I have R version 2.15 loaded (but also RStudio).

Does anyone have any ideas?

4
  • How did you install rpy2? Did you use pip?
    – Simbamangu
    Apr 4, 2012 at 7:57
  • What is the output if you start the Python interpreter and type in from rpy2.robjects import robject ? Do you get an error?
    – jlehtoma
    Apr 4, 2012 at 10:16
  • I installed rpy2 using the RPy2-2.2.4-1.dmg downloaded together with the other Python Modules required for QGIS.
    – Bruce Page
    Apr 7, 2012 at 12:41
  • When I enter from rpy2.robjects import robject in the Python terminal I get Traceback (most recent call last): File "<stdin>", line 1, in <module> ImportError: No module named rpy2.robjects >>>
    – Bruce Page
    Apr 7, 2012 at 12:48

1 Answer 1

2

A general installation will not work. You need to install to your QGIS python folder (e.g. C:\OSGeo4W64\apps\Python27\ (root folder), C:\OSGeo4W64\apps\Python27\Lib\site-packages (modules)).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.