1

I'm making a world map in QGIS 2.18 Las Palmas. The data came from Natural Earth using the WGS84 CRS, however I want to use a Robinson projection for my map. I reprojected the data, by clicking 'save as' and selecting World_Robinson for the output layer.

When I try to display a grid however, nothing happens. If the shapefile is in the original WGS84 I can get the grid to display in the composer, however it doesn't work with the grid CRS set to EPSG:4326 (WGS84) and the data has been reprojected into World_Robinson.

When I set the grid CRS to EPSG:54030, for World_Robinson, this happens.

How can I proceed?

I'm running MacOS El Capitan.

This is my first time using QGIS.

Edit: here is the grid with WGS84.

Grid

Edit 2:

enter image description here

  • The combination of EPSG:54030 (in meters) with a grid interval of 5 meters for the whole world certainly doesn't make sense. Show us settings you are using for your desired WGS84 grid. – underdark Feb 14 '17 at 20:32
  • @underdark I'm trying to follow this guide: qgistutorials.com/en/docs/making_a_map.html which suggests that I can have my data projected in Robinson, but use WGS84 for the grid. 5 was the suggested interval in that tutorial. Here are the settings I'm trying to use for the graticule. Ideally I'd like to have the unites in degrees. – Ben Feb 15 '17 at 6:09
3

You need to set the interval unit to CRS units instead of map units because map units are meters if your map is projected to EPSG:54030.

  • OK thank you so much for your help, and for being so patient. When I try to do this however, the only options that are visible are map units, millimeters, and centimeters. Is there something I need to do to enable selecting CRS units? I've attached a screenshot above. – Ben Feb 16 '17 at 0:08
  • Update: I got it to work! The only issue is that the grid only appears when I am zoomed in on the map. So for example, if I want to display only Japan, or only Europe, the grid lines will appear. If I zoom out however, to display the whole world, and there is white space around the map, the grid lines will not show up. Do you know if there is a workaround for this? – Ben Feb 16 '17 at 0:35
  • When the map is small scale, the grid will work. If I move the map content in the print composer the grid will move with it. If however, I try to make a large scale map, and display the entire oval shape of the robinson projection, the map becomes detached from the grid, or the grid simply disappears. docs.google.com/document/d/… The first is the small scale map, the second the large scale (156848459) where the grid has become detached, and the third where a new and identical grid is not visible from the start. – Ben Feb 16 '17 at 4:22
  • @Ben seems like this should be a bug report – underdark Feb 16 '17 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.