Can someone provide insight into why qgis becomes unresponsive when i try to add a raster layer? Specifically a .sid raster from NAIP imagery. I can no longer add these raster layers to projects, even to projects which already have raster layers from the same source (NAIP *.sid)added previously. The same .sid raster files that will not load now have been successfully added to qgis projects in the past.

What I have tried: Uninstalled qgis 1.7 and replaced with qgis 1.7.4 using the OSGe04W installer. Moved raster files from external to internal hard drive. Freed up internal hard drive space (>25% of capacity). Tried multiple raster files. I only have 1Gb of RAM, but this has been sufficient in the past. The raster file sizes are on average around 750Mb.

  • 1
    Could be a problem with SID support. Try to install following this guide: northrivergeographic.com/archives/1502 – underdark Apr 4 '12 at 14:49
  • 3
    It could be that if the SID support is not working properly, then QGIS is treating this as a standard raster, and trying to load the entire image into memory. With only 1GB of RAM, this is going to cause some severe performance issues, which could cause QGIS to become unresponsive. – Get Spatial Apr 4 '12 at 15:41
  • I would recommend that you check the integrity of the files by perhaps loading them with other software. Since you did the OSGeo4W install, you could use gdalinfo [filename] from an OSGeo4W command prompt to check. If GDAL won't read the file, then QGIS is not the issue. – Scro Apr 4 '12 at 16:01
  • have you tried this woostuff.wordpress.com/2011/08/08/… – Nathan W Jun 3 '12 at 22:25

I don't under which system your QGIS runs but at least for Mac OS X one has to install the plugin for the gdal framework: http://www.kyngchaos.com/software/frameworks

| improve this answer | |
  • Thanks all for the quick responses. I reinstalled QGIS 1.7.4 from the standalone installer as the northrivergeographic.com/archives/1502 article suggested by underdark recommended. What is baffling is sid files still will not load, but sid files already added in existing projects are fully functional. My OS is Windows XP. I have loaded hundreds of these files in the past. The files that are functional in existing projects in the current installation will not now load. Could SID support be malfuctioning yet still allow proper function in loaded data sets? – L Fuller Apr 4 '12 at 16:58
  • For what it's worth there is a file named gdal_MrSID.dll located in my C:\Program Files\Quantum GIS Wroclaw\bin\gdalplugins directory. Does this indicate a more basic system problem as Scro suggests? Thanks. – L Fuller Apr 4 '12 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.