3

I am trying to reduce a world map raster layer (North America, Pennsylvania, etc.) I thought I could do Raster>Extraction>Clipper - I selected the raster layer and the destination of new tif file, used the select tool to select the extent area to extract. But I keep getting this error:

ERROR 1: Currently GMT export only supports 1 band datasets.

Can I only clip or extract raster layers that have 1 band only or am I doing something wrong? This raster layer has a render type of Multiband color.

enter image description here

  • You have somehow selected GMT gdal.org/frmt_various.html#GMT as the outputformat. Use GeoTIFF -of GTiffinstead and you should be fine. – user30184 Feb 14 '17 at 21:20
  • Thank you for the response. It looks like I get the error when I select GeoTIFF. Do you know if there another format I could try? – joe d Feb 14 '17 at 21:36
  • What is the error now? What format your input file has? Can you give a link for downloading some similar file? – user30184 Feb 14 '17 at 21:39
  • I get the same error - I think I had GeoTIFF selected originally as well - The data came from this site: shadedrelief.com/natural/pages/download.html. Although I am having trouble locating the exact one I chose at the moment - I think it was a variation of 'Landcover, shaded relief, water' It is a very large tiff file. – joe d Feb 14 '17 at 21:47
  • I have just experienced this very issue and could not find a fix until seeing this post. In my case, I am trying to merge GeoTiff images into a single tif file. The GMT error would come up. I have been using QGIS for a few weeks without having this issue. I also get the same error when trying to convert a single tif image to jpg, also not a problem until now. Somehow, the -of command is defaulting to GMT now. I uninstalled QGIS, all of its registry entries and associated files, but still have the issue after reinstall. I will post a bug report, but am waiting on account approval from the bug s – Paul Marsh Aug 17 '17 at 16:59
4

I can see the output format switch in the gdal_translate dialog box is set to '-of GMT' despite the file extension '.tif'. This means that, although you think you are trying to export to GeoTiff, you are still telling GDAL to use the GMT driver and so you will continue to get the same error until you correct this. For GDAL it is the choice of output format driver that is important and not the file extension.

Clipper defaults to Geotiff, so opening a new dialog and ensuring that 'Save as type:' in the file-system dialog points to GeoTiff should fix this. You must have selected GMT in some previous operation and Windows has retained this choice for the file system save-as option.

Because the default is GeoTiff, if you see the '-of' switch in the text area at the bottom of the clipper dialog bog (see your own screen shot), then you have most likely done something wrong (unless it says '-of GTiff'). Note that you can actually edit these options by pressing the little yellow pencil button to the right side of the text area and edit where it says -of GMT to read -of GTiff. Refer to the documentation for further information - A list of supported formats and their limitations can be found here.

  • Thank you both for your help. Editing the format (-of GTiff) manually worked and the process completed. I have never set it to any other format and definitely had GeoTiff selected as the option in the drop down box, so it looks like it is defaulting to '-of GMT' on its own, even after GeoTiff is selected. Maybe a bug? Thanks again for finding a solution! – joe d Feb 15 '17 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.