1

I recently clipped a raster layer to a smaller extent. When I import this layer and assign it the same CRS as other layers (EPSG:4326, WGS 84) it does not project with them. The original pre-clipped raster layer projects correctly as do CSV data points that I have imported. I checked the Project properties and it also has EPSG:4326, WGS 84 assigned. Is it possible that the clipped layer is in meters instead of degrees? How would I determine if each layer is using either meters or degrees? enter image description here

enter image description here

enter image description here

  • It looks to me that the clipped raster has somehow lost its spatial reference, that's why the original raster is fine, other data (the CSV) displays correctly, and the clipped raster is looking the way it is. – JohnR Feb 15 '17 at 21:04
2

You may want to try using the Raster>Clipper and a mask polygon in order to clip your raster while maintaining its spatial validity.

All you need is your base raster that's going to be clipped and a vector polygon of the area you want to clip from your raster. Then you can go to Raster>Extraction>Clipper.

Raster & Clipping Polygon

In the Clipper, set the name and location for your raster clip output, select Mask Layer as your Clipping mode, set your clipping polygon as the Mask layer, choose whether or not to use the extent of the mask layer as the extent of the clip output (you probably want to), and choose whether or to keep the input resolution or set it to set it yourself (you probably want to keep the input resolution).

Clipper setup

You should end up with a clipping of your original raster that maintains its spatial reference.

Clip Result

Alternatively, if you don't have a polygon layer to use and would rather just draw a quick polygon to crop your raster with:

Instead of using a Mask Layer, you can use the Extent option in the Clipper tool and just draw a box or type in the bounding coordinates of what you'd like to clip out.

Extent Option

With the Extent option toggled on, you can click+drag a box to use for clipping. Once you get some coordinates showing up in the x,y fields of the tool, you're all set to clip.

Specified Extent

End Result

  • Thank you - I have noticed that option. I am not sure how to create a mask polygon. If you can direct me to a thread on that subject I will try it! Thanks again for your help! – joe d Feb 16 '17 at 15:22
  • I've expanded my answer to also show you how to use that tool without needing a premade mask polygon. – JohnR Feb 16 '17 at 16:04
  • Thank you - I have been able to clip my raster using the extent method - but I end up losing the CRS. I would like to try the mask method if that will help me keep the CRS. Alternately I would like to be able to give my clipped extent the correct CRS that it lost in the process. The methods I have used (Right Click on Layer>Properties and selecting the same CRS that my data points and Project have) doesn't seem to work. – joe d Feb 16 '17 at 16:17
  • I don't suspect that using a mask polygon instead of drawing the extent would have any impact on the problem you're having. I'm guessing that rather than simply losing reference to which CRS it's supposed to use, the exported clip is no longer georeferenced at all, which is certainly odd. What version of QGIS are you using? – JohnR Feb 16 '17 at 16:31
  • UPDATE: I was just able to clip to extent and have it successfully transfer over the correct CRS as well. Thank you for your help. I would like to learn how to create a mask layer and be able to use that clipping method as well. I am using Las Palmas 2.18.3 – joe d Feb 16 '17 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.