2

I am classifying an .adf wind resource map which I vectorised using the Polygonise tool (which worked very well). I have classified the data using the Graduated symbol renderer using Natural Breaks (Jenks) mode. Unfortunately although the Range column will take decimals, only columns with whole numbers will render. Does anyone know if there is a way to do this. Am using QGIS 1.7.3.

closed as off-topic by mgri, Midavalo Feb 23 '17 at 22:11

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – mgri, Midavalo
If this question can be reworded to fit the rules in the help center, please edit the question.

2

Interesting. This looks like a bug. I can replicate your problem using the Area column and manually adding classes which use decimal ranges. However if I use the [Classify] button to auto-populate the ranges it all works.

Investigating a bit further reveals the automatic ranges are floating point numbers with exponents, e.g. 2.29803e+10. If edit the class and strip e+10 those polygons will no longer draw. At the same time the legend range changes from 22 trillion something to 2.2 something. So I venture to get your splits working right you'll need to figure out what the exponential equivalent to your desired decimal is.

On windows 7 this can be done with the built in Calculator program. Just fire it up, set View to Scientific, enter a decimal and than tap the [Exp] button.

To convert in python, try this:

>>> '%e' % 55.23
'5.523000e+01'
  • Many thanks. Have tried various things, to no avail, (I found having 97,000 records doesn't help, although to be honest I have no experience in anything but the most basic GIS which is my real problem!). You mentioned using Classify, this is how I worked it in ARCGIS but I have switched to QGIS and Classify does not seem to be an option?? I am an OS X user so cannot access the Calculator programme. I input your code in Python but don't know enough to go any further. I have looked at various Python guides but found them daunting. Could you point me in the direction of a simple guide? – TedW Apr 7 '12 at 9:54
  • @TedW, on the Layer Properties >> [Style] dialog>> Graduated* dialog there is a [Classify] button near bottom left, see imgur.com/tYXoO. It may be a version thing. I'm using 1.7.4 on Windows. – matt wilkie Apr 8 '12 at 23:38
0

My error, I used the Classify button all along. The problem seems to be that the converted column, DN, has a precision level of 1 whereas I need something like ±0.2.

Not the answer you're looking for? Browse other questions tagged or ask your own question.