6

I'm new to QGIS, and am using v2.18.3 with the cloud plugin. I've published a map to the cloud, but am having problems with an attribute field in one of the layers. It's a URL field, and the data contains http strings for some rows and https for others. The http strings are properly displayed as hyperlinks and open up a new tab when clicked. The https strings seem to be processed as normal text (no hyperlink, no action performed when clicked.) Is there some trick to getting the software to process https strings as hyperlinks?

4

For SSL (HTTPS) you will need to authenticate before you access.

In QGIS>Settings>Options>Authentication [Tab] >Certificate Manager >Custom Certificate Configuration you can apply your login credentials.

enter image description here

SSL(HTTPS) might have a time limit so you maybe have to repeat this each time you connect (depending how the server-side is set up).

  • Thanks. I'll tinker around with this and see what happens. – Brian Feb 22 '17 at 16:21
  • It looks like the required websites do have time limited certificates. This could be an issue. The features in my map have more detailed information available through the URLs, and I would like for a user of the map to be able to use his own credentials to access it. Is there any option for performing an open webpage action without prior ssl authentication? I'm ok with a user being presented with a new tab requiring a login. – Brian Feb 22 '17 at 16:49
  • if SSL HTTPS you will require a login if HTTP that can be done without. – Mapperz Feb 22 '17 at 17:00
  • Thanks. I've tested one of the domains, and know I can trick it by just removing the s, since it puts it back in automatically. I'll have to test the other one to see if it handles things the same way. – Brian Feb 22 '17 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.