2

I'm attempting to generate a tile cache in ArcGIS 10.3 where one of the input layers is a DEM raster. The resulting tile cache displays all layers as expected, except for the raster layer. The output tile images show the raster as if it had all the correct settings but simply seems to ignore the hillshade effect that has been applied. The images below illustrate how the raster is originally symbolised (left) vs how it is showing in the tile cache (right).


Min-max stretch - Expected vs Actual

Min-max stretch - Expected Min-max stretch - Actual


No stretch - Expected vs Actual

No stretch - Expected No stretch - Actual


The resulting tiles do seem to take into consideration at least some of the stretched raster settings (e.g. the gradient, stretch type, etc), just not the hillshade.

Should this be happening?

  • How did you apply the hillshade effect? – Midavalo Feb 23 '17 at 6:26
  • I applied it I through the symbology tab in the properties window. – nwduncan Feb 23 '17 at 13:19
1

I was able to resolve the issue. Instead of applying the hillshade effect through the symbology tab in the layers properties window, adding a function to the raster in the Image Analysis window seems to be the correct way to get a hillshade effect working in a tile cache export.

First highlight the correct raster at the top of the window and click the Add Function button.

enter image description here

Next right click and apply the hillshade function to your raster. enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.