I had installed QGIS 2.18.3 using OSGeo4W and then the OTB standalone binary. In QGIS, I had manually entered the directory of the

  1. OTB applications folder (C:\Program Files\QGIS 2.18\apps\OTB-5.10.0-win32\lib\otb\applications) and

  2. Command line folder (C:\Program Files\QGIS 2.18\apps\OTB-5.10.0-win32\bin)

and I had checked the "Activate" button.

But nothing happens when I close the Processing window and there is no OTB menu appearing in the Processing Toolbox.

How can I resolve this issue?

  • 1
    If you restart QGIS, does OTB menu appear?
    – Kazuhito
    Commented Feb 23, 2017 at 11:34
  • Yes, I did restart QGIS, but it still doesn't appear. I'm trying with an older version of OTB. Maybe then it might work. Commented Feb 23, 2017 at 11:58
  • I have followed the above steps, installed OTB and QGIS,and entered the above paths for 'applications folder' and 'command line tools folder'. When I Confirm OK, I get a message : "Wrong value for parameter "Msys Folder":![enter image description here](i.sstatic.net/kxbUZ.jpg) (see image). What may be the issue ?
    – David
    Commented Aug 2, 2017 at 20:09
  • This is a GRASS issue, remove path to msys in GRASS GIS 7 commands and GRASS commands. Then, you'll be able to click ok.
    – aldo_tapia
    Commented Aug 2, 2017 at 20:45
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review
    – Oto Kaláb
    Commented Aug 2, 2017 at 21:10

3 Answers 3


You can use OSGeo4W to install the OTB Libs. Run the setup again and choose Advanced Install then go through the options until you can select the packages. Type in otb in the search tab:

Select packages

Then click each package as shown in the red box (I installed it before taking snapshots). Finish the installation then load QGIS and go to the Processing Provider options and enter the following paths as described here:

OTB applications folder: C:\OSGeo4W64\apps\orfeotoolbox\applications
OTB command line tools folder: C:\OSGeo4W64\bin

Processing Provider options

Confirm and hopefully (you might need to restart QGIS) you should see the Orfeo Toolbox in your Processing Toolbox:

Orfeo Toolbox

(Thanks for your question, I was meaning to get this working on my computer!)

  • 2
    Thank you for your suggestion. I will install from scratch. I was hoping I could avoid this. I'll let you know if it works. Thanks! :) Commented Feb 23, 2017 at 12:28
  • @AdrianLyngdoh - Most welcome! I tried yours (and Kazuhito's) method of downloading it directly from here but couldn't get it to work strangely...but hopefully this might work :)
    – Joseph
    Commented Feb 23, 2017 at 12:30
  • 1
    It worked, finally! Thanks again. :) For whatever reason, the method I tried never worked even with older releases of OTB. But your method is the most convenient way of installing the package. Commented Feb 23, 2017 at 18:01
  • @AdrianLyngdoh - Most welcome, glad it worked =)
    – Joseph
    Commented Feb 24, 2017 at 10:31
  • 1
    Note that these steps are for 64 bit Windows, 32-bit OSGEO4W goes in a folder named `C:\OSGEO4W`.
    – AndreJ
    Commented Jul 19, 2017 at 9:22

I had the same problem and I think it is due to the space between "Program" and "Files" in "Program Files". Try moving the OTB binary package to your C drive and repeat the process (Making sure there are no spacews in your file folder path). Then restart QGIS. This worked for me.


In addition to the above workarounds on the OTB not activated on 2.18 QGIS, turns out that the Boundless Desktop has the libraries and the bin ordered correctly, so you can just do a clean install with Boundless and this issue is resovled: https://boundlessgeo.com/boundless-desktop-gis-software-mapping-solutions/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.