1

Processing a map file with use of mapscript_csharp.dll (version 7.0.1) and map contains a few WMS HTTP layers and some are local shapefiles.

After upgrading from Mapserver 7.0.1 to latest version 7.0.4 by copying necessary (e.g.cgi-bin) dll's to my application bin and correct versions of libmap/mapscript dll (concerning oracle) I get an error when executing the map.draw() function (using the same map as with 7.0.1):

"drawGDAL(): Unable to access file. GDALDatasetRasterIO() failed: libpng: bad parameters to zlib" [System.ApplicationException]: {"drawGDAL(): Unable to access file. GDALDatasetRasterIO() failed: libpng: bad parameters to zlib"} Data: {System.Collections.ListDictionaryInternal} HelpLink: null HResult: -2146232832 InnerException: null Message: "drawGDAL(): Unable to access file. GDALDatasetRasterIO() failed: libpng: bad parameters to zlib" Source: "mapscript_csharp"

If I remove the HTTP WMS layers from my map file it works.

Could someone explain what I am missing and/or what file could not be accessed?

If any other info needed, let me know.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.