2

I'm trying to use Add Join in Modelbuilder but it keeps giving me an error message "generic error". Funny thing is, it works fine if I do one Join but I need to do several ones (about 200s or something and I wanna do them at the same time of course).

I've tried Iterators and now succumbed to pasting the same simple formula in modelbuilder several times but it still doesn't work. Of course I could do this manually but I would rather not having to do that.

I've also tried Join Field but that took 9 minutes for one of these records, it would take hours upon hours since I need to do this many times.

Is this a common problem?

This is an image of my model which outputs error message after one second or so. Some text is in Swedish "alla_lgh_sweref" are my point dataset and the polygon shapefiles are in buffer50 geodatabase.

enter image description here

Error 999999: Error executing function. So it's a generic error that doesn't say much. I just try to run the model with the Add Join tool. It works fine if I do it manually, but if I try to batch and/or model it doesn't work.

closed as off-topic by PolyGeo Mar 6 '17 at 9:12

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 200 joins on the same source layer or on different source layers? – artwork21 Feb 24 '17 at 17:28
  • Two layers, 1 point data set and then several shapefiles. – Mutumba Feb 24 '17 at 17:50
  • 2
    Would you be able to post a screenshot of your attempt in model builder? – Fabien Ancelin Feb 24 '17 at 19:21
  • I have done that now, though maybe it's hard to tell what the problem is still. – Mutumba Feb 24 '17 at 22:28
  • 1
    The reason Join Field takes longer than Add Join is because it's permanently adding the fields and populating values. Add Join is temporary. – Paul Feb 25 '17 at 0:20