I was using 2.16 version and everything was alright, I could merge two layers via Vector - Data Management - Merge and use .shp format as saved output format. Unfortunately my working laptop was reinstalled and now when I installed same QGIS back - I can't use this .shp option (I have only dbf, csv, xlsx and ods) and it really drives me crazy. I removed 2.16 and replaced with 2.18 but still have same issue. I 2.16 I could at least use SAGA merge tools for it but in 2.18 I can't.

I am trying to merge and save two layers (shp with same geometry type and CRS).

Add: I tried to download QGIS 2.18.4, removed all registry files and every single file related to QGIS to make sure I don' t have any hidden setting in Windows folders but it didn't help.

I looked into all QGIS Settings I found and I just can't see anything related to it.

Tried Vector menu, Processing Toolbox and nothing.

Saved file drop down menu

  • When you say cannot select, you mean the physical file exists but you cannot select it in QGIS ? Did you try to open the file in QGIS separately ?
    – Shiko
    Commented Feb 28, 2017 at 10:09
  • I have shapefile and I can select layers for Merge but I can' t save them as shp.
    – DrottTom
    Commented Feb 28, 2017 at 15:45
  • it may be a permission issue, may be the folder where u r saving shape file is protected, either try to save in different place or try to open QGIS as Administrator and save the file.
    – Shiko
    Commented Feb 28, 2017 at 15:55
  • Same issue when you use the 'merge vector layers' under QGIS geoalgorithms|Vector general tools, or when you try to save it from the layer tree (cp. my updated answer below)? Commented Mar 1, 2017 at 8:46
  • You installed it from the installer downloaded from the website, not via osgeo4w installer? Commented Mar 1, 2017 at 8:57

1 Answer 1


I would recommend to use the merge tool from the processing toolbox. Activate the processing toolbox via Processing>Toolbox (Ctl-Alt-T) and search for 'merge'. In this tool you are not only restricted to two shapefiles, but you may select n from the loaded layers and merge them together:

enter image description here

The resulting merged vector can be saved as a shape file in various ways:

1) directly from the processing tool: click the three dotted button right beside [Save to temporary file], in the 'save as' dialogue from the combo select the file format you wish:

enter image description here

enter image description here

2) You may wish to preview your result before saving it. In this case, leave the [Save to temporary file] as it is, preview your result, and if it's ok, right click it in the Layer tree and select 'Save As...'. In the next dialogue you can select the file format you prefer:

enter image description here

enter image description here

  • I edited my question as I didnt ask correctly. My issue is for saving merged layers. I don' t have .shp format as an option there.
    – DrottTom
    Commented Feb 28, 2017 at 15:37
  • Ok... in that case I'll extend my answer as well ;-) Commented Mar 1, 2017 at 8:33
  • Thats exactly my problem... I don' t have .shp format there as an option for saving. Before Windows reinstall I always used this tool in same way and there was .shp ... :(
    – DrottTom
    Commented Mar 1, 2017 at 9:33
  • Ok. I found something. If I create new project and import same two shp (both points, same CRS) - as I tried to save before ... I have .shp as option for saving... But when I want to do it in my original Project I can' t save it as a shp again. I thought it is due different version of QGIS now, but my project was created in 2.16 version and after Windows reinstall I had 2.16. version again... I really don't understand.
    – DrottTom
    Commented Mar 1, 2017 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.