I've been using/testing several versions of various GIS software and run into occasional issues. Right now, my biggest with QGIS is with GPS connection/downloading from/tracking. These are all critical issues for me.

1.) I think I did finally figure out the need to set data transfer to NMEA in/out on my Garmin GPSMap60CSX. QGIS repeatedly crashed on clicking connect, I hope this was my only error and is now corrected.

2.) Downloading from/uploading to GPS unit... clicked to download tracks and waited 10 minutes before giving up and canceling with no success. Any tips/pointers?

3.) I've posted in the old forum about this one... I am unable to see any layers of the open project when live tracking. Last time (I think using Copiapo) I was eventually able to zoom until the .shp file was visible (basically stumbled onto that one), but not the .sid file that formed the base map. Now, using Wroclaw there is nothing at all visible except the gps track. Just creating a track doesn't help, I need to be able to see my location in relation to various physical features and property boundaries in real-time.

  • Can you try running one of the nightly builds to see if the crashing issues still happen. There was a bit of work in the GPS module to improve that.
    – Nathan W
    Apr 8, 2012 at 21:45

2 Answers 2

  1. I spent 9 hrs today with QGIS plotting real time data from a Garmin GPS. It does eem to crash after a few hours, perhaps when memory is filling up from the trackpoints. Yes, NMEA. Perhaps you have the wrong port? Port selection is supported better in Trunk.

  2. Sounds like you have got a rendering issue, are the rendering settings default? You will find that rasters are masked by the track of the gps, try setting the track to 0.



For 3)

I have found that you have to enable OTF (On the fly) CRS transformation (found in Project Properties) in order to get it to correctly render the GPS point on top of your base maps.

QGIS is getting the coordinates back from the GPS as WGS84 Lat/Long and just plotting them as such without doing any transformation so you must transform your layers into WGS84 using OTF.

Note: You will need to be running a nightly build in order get the sid files to correctly transform; the current nightly builds have raster OTF

  • OK, I'll see if that helps. I did find that things definitely improve for response time when I remove the .sid layer. Haven't had a chance to get back at the tracking in a few days. I'll check it out this weekend.
    – CCRGR
    Apr 17, 2012 at 0:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.