2

I've created sql view which will be calculate route between 2 points which are pass over service ... so here is Sql View configuration window: enter image description here

When I try preview layer I got this result on init:

{"type":"FeatureCollection","totalFeatures":0,"features":[],"crs":null}

So I've tried add parameters to url and execute it ... but with same result. Here is my url:

localhost:8080/geoserver/Maps/ows?service=WFS &version=1.0.0
&request=GetFeature
&typeName=Bachelor:Route &maxFeatures=50
&outputFormat=application%2Fjson
&viewparams=s:30623;t:6021

I tried execute query with parameters into pgAdmin, and works .. but here not :/ any ideas?

Bounding box of layer will be dynamically by entered points, so I add full range into bbox inputs like this: enter image description here

  • try turning logging up to GeoTools developer and then adding the relevant part of the log file - you should see the actual request being sent to the db – Ian Turton Mar 2 '17 at 8:55
  • When I check logs in Geoserver, that parameters are there, so I think issues will be on other place ... I found on other one forum that WFS not support parameters in SQL view ... dou you think is right? – Denis Stephanov Mar 2 '17 at 12:14
  • are they present in the logged request? – Ian Turton Mar 2 '17 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.