1

I recently joined an excel into attribute table on ArcGIS. The excel has been saved into csv format and the joining worked.enter image description here

Also, when I click on a feature, it shows all attribute fields. Now I repeated the process but it appeared some problems. The first lines which contains numbers is not appearing with a letter in front, like in the first screen, but like this: enter image description here Also, when I click on the feature, it doesn't appear the fields that I've added from the excel, but only the primary ones. Now, I removed all symbols that ArcGIS doesn't like from the excel, but with all that, I don't know what to do in order to overcome this problem. I know that it's something easy but I'm beginner and all this little issues can became very annoying because of my misunderstanding.

  • Which fields belong to the feature class and which to the joined table? I take it you've performed the join in ArcMap... if you want the fields to appear in the attribute table you need to physically join, not just virtually join, the table. Look at the Join Fields tool resources.arcgis.com/en/help/main/10.2/index.html#//… to permanently add the joining fields. I do not recommend using CSV for joins, too many things can go wrong. Try importing/saving to dbf (DBASE IV) format or Access (JET) format to make the join table more robust. – Michael Stimson Mar 2 '17 at 1:18
1

You need to click the drop down menu list at the top right of the Attributes windows buttons and check the Field Names option. It looks like the Field Alias option is probably checked in this drop down menu based on the snapshot of your data.

enter image description here

  • No, the fields from the first shot are different than those from the second one. Into the second photo, it appears, for features, only the input attributes of the layer, without the joined attributes. – Sam Lee Mar 2 '17 at 22:19
  • Comment removed. – Richard Fairhurst Mar 3 '17 at 4:49
  • I never use cvs or Excel for joins since they do not work for most things, because they do not have ObjectIDs. I always convert them using the Excel to Table tool to make them file geodatabase tables to eliminate all problems like this. – Richard Fairhurst Mar 3 '17 at 4:52
  • I`ve done it and it works, but when I clicked on a feature, the attribute fields appear with gray, not with black like in the first screen. After I made the join and I tryied unsuccesfully to copy and paste two features, the data from the fields disappeared. – Sam Lee Mar 3 '17 at 11:51
  • I assume you mean you created a file geodatabase table. Is that correct? I also want to be sure that you understand that the joined table cannot be edited in the joined view ever. Only the primary table.fields can be edited in that view. Edits to the joined table have to occur directly to that table while it is not joined or it is the primary table in the join. When you copy/pasted, were you trying to copy/past the entire feature or just some of the attributes into other fields? What fields are used to create the join? – Richard Fairhurst Mar 3 '17 at 15:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.