1

I have a point layer with meteo-stations data. When I tried to obtain filled contours with contour plug-in it seem ok, but when I tried to work with that layer happened a mistake and I don't know how to solve it.

As you can see in the picture below, in the areas pointed with black arrows doesn't have a value. For example, if you click with info button doesn't appear anything. If you point in the areas pointed with blue arrows, both areas appears selected (they have the same value).

I need to intersect this layer with another one, but algorithm doesn't run because there are invalid geometries (I guess will be those which can not be selected). How can I give this part of the layer its attributes??

enter image description here

3

You have multipart-polygons as the output of Contour plugin, which is normal. The attached image shows two red-highlighted areas (Upper-left and Lower-right), both selected by your click only on Upper-left area.

Try Vector | Geometry Tools | Multipart to Singleparts.

  • 1
    @RafaAgustí Thanks for your feedback, and sorry it did not work out. Can you possibly add some information so that you can get proper answers from experienced people? For instance, 1) it was not multipart polygons from the first place, 2) the tool did not work as expected, 3) the tool worked, but the issue still persists.etc... – Kazuhito Mar 7 '17 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.