1

Using ArcGIS Desktop 10.4.1, I am attempting to convert a FGDB line feature class to a raster using the Polyline to Raster tool. The input feature's value field contains integer values that range from -55,590 to -2,390, which would necessitate an 32-bit signed integer output raster. However, Arc will only (!) output a 16-bit signed integer, which means that values outside of the range -32,768 to 32,767 are lost. Grrr.

The Arc tool help states: "The input field type determines the type of output raster. If the field is integer, the output raster will be integer; if it is floating point, the output will be floating point." Not true! I have also tried a floating point field, and the output is always a 16-bit signed integer raster.

I've tried both FGDB raster and .tif as output raster formats, with the same 16-bit signed integer output - even though both formats are capable of 32-bit.

I've also tried the "Feature to Raster" tool, with the same results.

Neither of the tools has the option to set the output raster bits depth, nor does the Environments setting.

I am at a loss!

  • This appears to have something to do with all-negative values. Contact Tech Support, but the workaround is to negate your linear values, convert, then multiply by -1. – Vince Mar 6 '17 at 1:31
  • Out of curiosity, have you tried with field double and output to humble grid format? Perhaps adding 0.1. you can remove it later – FelixIP Mar 6 '17 at 3:29
  • @FelixIP, your suggestion worked - thank you! Furthermore, it worked for both the humble ;) Grid format, but it also worked for the raster FGDB format. In both cases the Polyline to Raster output was a continuous format, so I Raster Copy that to a 32-bit signed integer, followed by a Build Raster Attribute table. In summary, the input vector field needed to be double format, wherein the initial integer values had 0.1 added to them (the 0.1 part seems to be the crux move in the subsequent Polyline to Raster tool). This process failed with .tif format; not sure why but did not investigate. – Stu Smith Mar 11 '17 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.