6

I am working with the following ten landsat 8 images:

LC81340412016058LGN00
LC81350412016065LGN00
LC81350422016001LGN00
LC81360412015341LGN00
LC81360422016216LGN00
LC81360432016216LGN00
LC81370412015316LGN00
LC81370422015364LGN00
LC81380412016086LGN00
LC81380422016214LGN00

When I opened these images in QGIS with the supporting shapefiles it covered the entire state of Assam (in India). But After I tried to merge them using QGIS Raster tool the merged image did not cover the entire state. Only a small part of Assam was shown in the QGIS in the merged image.

Before merging

 landsat 8 images covering entire Assam

Before merging in QGIS

enter image description here

after merging in QGIS

  • 2
    What exactly are you doing step by step? – bugmenot123 Mar 6 '17 at 10:43
  • After clipping the lansat 8 images with shapefiles I want to do vegetation mapping and also use NDVI, NDWI etc. – A Salim Khan Mar 6 '17 at 11:11
  • First I would mosaic and then clip all the images for further processing – A Salim Khan Mar 6 '17 at 11:12
  • Just an idea: did you keep Place each input file into a seperate band merge option unchecked? If you checked it, your images are merged into one with many bands. Check metadata of created layer. – Oto Kaláb Mar 6 '17 at 11:31
  • Yes it was unchecked by default and I kept it as such. What will I get in the metadata of the created layer – A Salim Khan Mar 6 '17 at 11:39
1

You can merge them together using the QGIS Merge tool for rasters, see this tutorial: http://www.qgistutorials.com/en/docs/raster_mosaicing_and_clipping.html

enter image description here

  • I think OP used this tool but he is struggling whit its output. – Oto Kaláb Mar 6 '17 at 11:40
  • I have already tried this way but the output is not coming. The problem is somewhere else – A Salim Khan Mar 6 '17 at 12:03
  • do I have to use <build virtual raster> before merging? – A Salim Khan Mar 6 '17 at 12:08
  • 1
    No, @ASalimKhan, you don't. Just use the QGIS tool. You could show the configuration of the tool? – Alex Leith Mar 6 '17 at 21:01
1

It seems like when merging you lose the alpha information, because you have none or it's only set as Alpha value. Like that the areas surrounding your Images overlap the others, which results in black color.

You need to create an Alpha Band from that value for each individual raster image. Then merging should work.

With QGIS you can do that with the Tool: Raster -> Analysis-> Near Black

Set the in- and output file accordingly and then click the edit button and add "-setalpha" like in the Screenshot.

enter image description here

  • I am not getting the same 'Near black' display in Windows 10 QGIS as u are showing here. – A Salim Khan Mar 6 '17 at 12:24
  • the edit portions reads like this: nearblack -o "E:/GIS Data/landsat8_Data/Assam_landsat8/Assam_merged.tif" where do I put -setalpha- o – A Salim Khan Mar 6 '17 at 12:28
  • You can put it before the -o – pLumo Mar 6 '17 at 12:47
  • there are more than 40 tiff images of different bands. QGIS is taking only one image at a time. Is there a way to load all the images for setting alpha – A Salim Khan Mar 6 '17 at 13:18
  • After I tried to do this, QGIS returned the following "The process failed to start. Either the invoked program is missing, or you may have insufficient permission to invoke the program" – A Salim Khan Mar 6 '17 at 13:28
-1

Try to use gdalwarp utility from GDAL library. E.g. gdalwarp $(list_of_tiffs) merged.tif.

  • The question is about QGIS. – bugmenot123 Mar 6 '17 at 11:00
  • Sorry I have never used gdalwarp. Plz do tell me if this can be done in QGIS – A Salim Khan Mar 6 '17 at 11:14
  • @Dmitriy point to command line use of GDAL. If you are using merge from raster menu in QGIS, you exactly use GDAL - gdal_merge.py (you can see the final command at bottom of merge window) – Oto Kaláb Mar 6 '17 at 11:18
  • plz send a screen shot of how to use gdalwrap for mosaicing and clipping. – A Salim Khan Mar 6 '17 at 12:05
  • I am using ten tiff images each containing 11 bands 30 m resolution. file sizes are very large. may be there is a bug coming up in QGIS. – A Salim Khan Mar 6 '17 at 12:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.