2

I am trying to publish some raster data sets as WCS using ArcGIS 10.4.1 (Desktop ArcMap and Server Manager), but have had little success. I've attempted to publish a data set stored as an ESRI Grid, a Geo-tiff, and a Mosaic data set. I am able to connect to the WCS image server, but when I try to add the image I get the following message:

"Could not add the specified data object to the map. Failed to open raster dataset."

Here are detailed steps:

First I created the shared folder to register my data source with ArcGIS server. Next in ArcMap Catalog I navigated to to the registered folder and selected the required raster data set ( Geo-tiff both geographic and sinusoidal ) also created a Geo-database ".gdb" for a list of mosaic data set.

Next using ArcMap publishing Wizard, I have published the Image services as WCS and WMS both. When publishing my dataset, I select the WCS and WMS capabilities along with the Image Service and verified on the Server Manager that the services I created are available on server along with under WMS and WCS tabs.

Next I needed to check if I can get these WMS and WCS links work in ArcMap. I am able to add the image as a Image Service when I connect to the ArcGIS Server just fine. I'm also able to add the published data as a WMS ( can see the image in Data view ). The WCS is the only service that fails. Does anyone know what would cause my WCS to fail, but allow my Image Service and WMS work.

There was a bug report of dragging the WCS layers in Data view of ArcMap might be issue so I tried the add layer button to select the WCS layers from WCS server connection but it still failed.

Below link, it seems like when we add WCS service in ArcMap it atleast gives a black layer which can be contrast stretched to get the right image. But in my case I am not getting any layer just the error mentioned above.

http://docs.gina.alaska.edu/ndvi/how_to.html

Also there seems to be not issue in my Geo-tiff's as when I add these files directly to ArcMap it will show up layers / images also using WMS it works.

Last, I also tried the same WCS service GET Coverage operation in browser and I got a Tiff Image downloaded. ( So same WCS service working in browser but not in ArcMap )

https://localhost:6443/arcgis/services/imageservicename/ImageServer/WCSServer?SERVICE=WCS&VERSION=1.1.1&REQUEST=GetCoverage&IDENTIFIER=1&FORMAT=image/GeoTIFF&BOUNDINGBOX=-124.45790612602009,40.000531011912074,-91.378950375060455,49.999999995506855,urn:ogc:def:crs:EPSG::4326

1

So after talking to ArcGIS team it comes out that only for "WCS server" inside ArcMap we have to use link with Qualified domain name instead of using localhost. I tried with that link and it worked fine while bringing WCS Coverage in Arcmap.

https://serverqualifieddomainname:6443/arcgis/services/imageservicename/ImageServer/WCSServer?SERVICE=WCS&VERSION=1.1.1&REQUEST=GetCoverage&IDENTIFIER=1&FORMAT=image/GeoTIFF&BOUNDINGBOX=-124.45790612602009,40.000531011912074,-91.378950375060455,49.999999995506855,urn:ogc:def:crs:EPSG::4326

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.