1

I used ArcCatalog 10.2.2 to connect to enterprise database (SQL SERVER 2012) I've created before.

Some feature classes load just fine. But others show this error when I try to view data tableenter image description here

This feature class works fine in personal DB, this error only happened in Enterprise DB.

Thing I've tried:

  1. Re-install SQL Native Client 12
  2. Export error feature class and re-import to DB

Anyone has a solution for this?

  • 1
    Welcome to GIS SE! As a new user be sure to take the Tour to learn about our focussed Q&A format. Please always include error messages as text rather than pictures so that they can be available for future searches. – PolyGeo Mar 7 '17 at 5:38
1

So,I've found out what really cause to this error.

  • My region setting define that "," is decimal symbol and "." is digit symbol
  • When i tried to connect to SQL Database ArcGIS has problem reading double field from my feature class

I've changed my region setting and now it works perfectly.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.