1

I can see all my map layers in Layout view but get a blank white screen in Data View. Every help resource I searched seems to show thousands of questions and answers for the opposite problem.

I have tried zoom to layer and zoom to visible. I have tried setting display to wire frame and to always display. There are no red x's on any of the map layers and the source path's have not changed. These were all working fine yesterday.

This morning it was good, then I zoomed in and got a blank layer, zooming back out didn't return to the previous map. Pulling my hair out. Using military map deck made for CPOF, if that information is helpful to anyone.

Version 10.1 Problem exists on all saved and new mxds. Problem exists at all scales.

  • Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format. What version of ArcGIS are you using? Can you include a screenshot illustrating the problem? Please edit your question to include any response to comments and additional information. – Midavalo Mar 7 '17 at 16:50
  • What is your scale set to? – Midavalo Mar 7 '17 at 16:59
  • 1
    Which data frame is active? Perhaps one with no data to display – FelixIP Mar 7 '17 at 17:20
  • I didn't know there were different data frames in data view. This sounds promissing. How do i change data frames in data view? – Joshua Combs Mar 7 '17 at 17:39
  • 2
    Activate data frame in layout view, switch to data view – FelixIP Mar 7 '17 at 18:36
0

Turns out it was a memory problem. Split up the personal geo databases and it works fine now.

I had one personal geodatabase with multiple Military Analyst catalogues in it. When I switched to just one MA catalogue in each file geodarabase it worked.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • Glad to hear you got it sorted. Could you edit your answer to expand on the problem and how you fixed it? This could be useful for other users in the future if they run into the same problem. – Midavalo Mar 10 '17 at 18:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.