1

Suddenly with QGIS 2.18.2 on Mac OSX 10.12.3, when I import a CSV as a vector layer, the layer properties > style and >labels dialogs are completely blank. It was working before. Same files work fine with QGIS 2.14.0 on windows 10. what gives? Is there a setting I can tweak? a dependency? like JavaScript or a plugin?enter image description here

1

Another problem I noticed that can cause this problem is having numerical coordinate columns incorrectly formatted as text in your source file. QGIS doesn't know how to plot the data. For me this caused coordinates to have 1,000 comma separators causing 7003450 mN to be interpreted as "700,3450" and dislocating all my data.

You can solve this problem in excel by converting the text to numbers and removing commas, or by specifying a different delimiter on the import dialog for text delimited files in QGIS.

| improve this answer | |
  • But, this is a QGIS problem or a file problem? You can avoid this changing language setting and after that, open in Excel and save it with a different format – aldo_tapia Nov 27 '17 at 10:15
  • I had the same issue. Make sure that all your values in the spreadsheet are properly formatted. – Stockfisch Dec 6 '17 at 12:29
0

I found the problem. I was importing the CSV as a vector layer rather than a delimited text layer. Importing a CSV file of non-spatial data as a vector file is what you do when you want to join the CSV to a shapefile (Layer>Add Layer>Add Vector Layer). But if the CSV has spatial data (usu. point data in lat lon) you import it as a Delimited Text Layer (Layer > Add Layer > Add Delimited Text Layer).

I'll leave this question up here in case it helps someone else making same rookie mistake.

| improve this answer | |
  • Can you please edit your answer to expand on what you did wrong and what was the correct solution – Midavalo Mar 8 '17 at 21:58
  • Don't forget to accept your answer by clicking the green-faded tick on the left-hand side :) – Joseph Nov 30 '17 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.