I'm trying to add a WMS to QGIS from GeoServer from localhost but after I paste in the URL and go to connect I get the following error:

Failed to download capabilities:
Download of capabilities failed: Error downloading http://localhost:8080/geoserver/geog585?SERVICE=WMS&REQUEST=GetCapabilities - server replied: Not Found

I'm pretty sure I typed in the right parameters but I'm a total webmap nube so I could be off:

enter image description here

enter image description here


3 Answers 3


You are confusing the workspace URI with the server URL.

The workspace URI is a way of distinguishing different workspaces and is mostly used in WFS responses. For QGIS (and other clients) you need to provide the URL that points to the WMS endpoint. There is one main one http://localhost:8080/geoserver/ows which provides access to all the workspaces and layers in your GeoServer instance. GeoServer also provides virtual services which have URLs like http://localhost:8080/geoserver/topp/wms where the workspace name (topp) is used in the URL which limits access to just the layers within that workspace.

  • I was confusing them. I typed in Son of Beach's solution and it worked, although I could have sworned I initially tried to connect to localhost:8080/geoserver/wms? . The only difference this time was that I excluded the question mark.
    – geoJshaun
    Mar 9, 2017 at 18:51

In QGIS, enter the URL as:

If it still doesn't work after that, navigate to the following URL in your web browser, on the same local machine as Geoserver, and tell us what you get: http://localhost:8080/geoserver/wms?SERVICE=WMS&REQUEST=GetCapabilities

You can see the standard Geoserver WMS URL format in the Geoserver documentation at http://docs.geoserver.org/stable/en/user/services/wms/reference.html where it says:

A example GetCapabilities request is:


(...and in other examples on the same page.)

You don't need to include your namespace specifier in the master WMS URL. Geoserver will send the more specific URLs for each layer to QGIS when it gets the GetCapabilities request. QGIS can figure out the URLs for each layer from there.


Try the url:


the service name is ows/wms/wfs. Not geog585 as far as I can tell.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.