2

I draw a polygon on my map and I need to know if there are some features in it via WFS to get back a JSON. I guess I need to use CONTAINS property but when I read it it says that a contains b.

So I tried to write

https://myurl.com/geoserver/wfs?service=wfs&format_options=id_policy:reference_no=false&version=1.1.0&request=getfeature&typename=biglayer:layer&outputFormat=application/json&CQL_FILTER=CONTAINS(POLYGON((465995.8321513263%205177213.444093402,525922.4623269045%205157645.564852396,434809.5246109744%205123401.776180638,465995.8321513263%205177213.444093402)),geom)

But I've got the error

Binary geometry filter, but first expression is not a property name?

If I put geom in first position, it returns me 0 feature, and I don't get it neither...

EDIT : Well I finally understood that I have to use WITHIN but I've still got no result... Here's my url :

https://myurl.com/geoserver/wfs?service=wfs&format_options=id_policy:reference_no=false&version=1.1.0&request=getfeature&typename=biglayer:layer&outputFormat=application/json&CQL_FILTER=WITHIN(geom,POLYGON((465995.8321513263%205177213.444093402,525922.4623269045%205157645.564852396,434809.5246109744%205123401.776180638,465995.8321513263%205177213.444093402)))

Any clue?

closed as off-topic by nmtoken, whyzar, Mapperz Mar 9 '17 at 21:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – nmtoken, whyzar, Mapperz
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Are you expressing coordinages in the layer native CRS? That's a requirement for CQL filters. – Andrea Aime Mar 9 '17 at 16:50
  • also are you sure your geometry column is called 'geom'? – Ian Turton Mar 9 '17 at 17:08
  • @AndreaAime Yep that was a CRS issue. I've been mistaken because of the srs condition with the bbox filter I used before. Thanks :) – So4ne Mar 9 '17 at 18:29
  • @iant yep it solved, was a native CRS issue. Thank you ! – So4ne Mar 9 '17 at 18:30

Browse other questions tagged or ask your own question.