1

I am trying to import .las files in PostgreSQL database. The .las files are from https://viewer.nationalmap.gov/basic/?basemap=b1&category=ned,nedsrc&title=3DEP%20View. The issue is the file is in Lambert Conformal Conic projection and my remaining map data is in WGS84 projection.

I tried converting las file using las2las, but getting error:

could not import coordinate system into OSRSpatialReference SetFromUserInput

I was following the tutorial https://gist.github.com/YKCzoli/3605e014b8ed09a571e5. But this tutorial does not talk about projection conversion.

Steps I followed:

  1. las2txt -i SFdowntown.las -o SFdowntown.txt
  2. copy elevation(x,y,z) FROM ‘~/Desktop/LiDARExtract/SFdowntown/SFdowntown.txt’ DELIMITERS ',';

closed as unclear what you're asking by Andre Silva, PolyGeo Mar 29 '17 at 22:16

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Welcome to GIS SE! As a new user be sure to take the Tour to learn about our focussed Q&A format. – PolyGeo Mar 10 '17 at 6:19
  • Which code/parameterization did you use when calling las2las? – Andre Silva Mar 28 '17 at 20:33
  • I was using las2las with -a and -t parameter with source and target projections. I have already solved the problem by adding the data in postgres with las2txt and then using ST_Transform() function of postGIS. I was able to find lambert conical projection for Santa Clara county at: epsg.io/102643. – Swapnil Gaikwad Apr 3 '17 at 2:01