1

The matching ID fields are identical, there are no extraneous spaces or anything like that. I exported the feature class and table to a gdb, and it joins all but one record (still no difference in the IDs). I need to do this for multiple feature classes. It makes no sense to me that it works in a gdb but not in an mdb.

And yes, the data has to be in a mdb - it's for modelling software.

EDIT:

The field types are identical - string with lengths of 32 in both. No spaces, no dashes, fields start with a letter.

So I just tried joining the exported feature class with the original dbf, and that only matches 90%. But when they are in the same gdb, it does all but one record.

"C_LRC_RCD2_100" is a matching record.

"C_LRC_RCD2_MT_20" is a non-matching record.

Using ArcGIS 10.3.1


Could it have something to do with the feature class join field not being indexed?

It is a simple, one-to-one join

Text from 'Validate Join':

All field and datasource validation tasks were completed successfully.

The number of matching records for the join: - 288 of 317 records matched by joining [INFO_COND_ID] from with [ID] from . Matching records may not appear in table view due to join validation errors.

"C_LRC_RCD2_MT_2" is a matching record, "C_LRC_RCD2_MT_20" is a non-matching record:

"C_LRC_RCD2_MT_2" is a matching record, "C_LRC_RCD2_MT_20" is a non-matching record.

  • 3
    Are the field types identical? No spaces? Can you edit your question to include examples of both matching and not matching records? – Fezter Mar 13 '17 at 19:51
  • 1
    Are the records that are not joining distributed throughout the table, or are they at the beginning or end? If they are grouped, it could be an issue with the records themselves, or other attributes causing the problem. I've also had issues with 1 record cause nothing after that record in the table to be read properly. – Get Spatial Mar 13 '17 at 21:16
  • There are several different groups, all with varying amounts of unmatchhed records. – Brandon G. Mar 13 '17 at 22:20
  • 1
    Need more information. Is this a new .mdb? Have you tried creating a new personal gdb, importing the data, and trying to do the join? Is the version of the PGDB the same as the version of ArcGIS you are using? This really shouldn't make a difference, but you need to start eliminating possible variables. This might be a stupid question, but is this a 1-1 join? What are some of the other records that joined properly in the FGDB but not in the PGDB? If possible, please include screenshots of each table, to show more of the data. What messages do you get when you Validate the Join? – Get Spatial Mar 13 '17 at 23:33
  • @GetSpatial I edited the original post. – Brandon G. Mar 14 '17 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.