1

I have downloaded the Terrain Mapping Toolbox in order to use in a project that was assigned to me. However, I want to define it as a permament toolbox in ArcMap, similary with the main toolboxes that are offered through ESRI(e.g Spatial Analyst, Data Management, Conversion etc.).

I tried to place it in this directory (C:\Program Files (x86)\ArcGIS\Desktop10.4\ArcToolbox\Toolboxes), but didn't work. I thought that locating Terrain Mapping toolbox at the same directory with the rest main toolboxes, that would work.

Is there any suggestion which will enable me to set Terrain Mapping as a default toolbox?

  • 1
    Ensure you only have one Catalog open and your customize mode isn't set to readonly then add the toolbox to the tree by right clicking at the root and select 'add toolbox', it doesn't need to be in your 'my toolboxes' folder but needs to be accessible at the time Catalog starts.. exit ArcCatalog and reopen the application and it should appear. Do the same for ArcMap. It is crucial that only one instance is open when you add the toolbox as the last to exit writes the normal (.gxt and .mxt respectively). – Michael Stimson Mar 13 '17 at 22:06
  • This works only at Catalog label, however, ArcToolbox label (Geoprocessing > ArcToolbox) doesn't recognize Terrain Mapping toolbox. I am trying to figure out why does this happen. Both labels contain the same toolboxes (except Terrain Mapping in ArcToolbox), in the same directory. ArcToolbox seems to be slightly dysfunctional. – Marios Simou Mar 13 '17 at 22:29
  • 1
    Is it possible your toolbox isn't the right version? try creating a new toolbox in the catalog tree then copy/paste the tools from the Terrain Mapping Toolbox.. of course it could be a licensing issue, terrain mapping requires 3d analyst, if the extension is disabled or your license seat does not match and hide locked tools is checked it is possible the toolbox is added but not shown - try unchecking hide locked tools and see if it comes up. – Michael Stimson Mar 13 '17 at 22:33
  • Eventually, there wasn't any problem with 'hide locked tools'. I had to follow the below procedure: Right click at ArcToolbox Label > Save Setting > Default.. Now everything seem just as I want! Thanks – Marios Simou Mar 13 '17 at 23:21
1

Ensure that only one ArcMap and/or ArcCatalog is open before attempting this.. this is because the last to exit will overwrite the Normal.gxt (Catalog) or Normal.mxt (ArcMap), in this file customization for all future sessions is stored. As an aside these files are precious and become more so with each customization and I suggest they should be part of your backups on a regular basis, on Windows find them in:

%USERPROFILE%\AppData\Roaming\ESRI\Desktop<version>\ArcCatalog
%USERPROFILE%\AppData\Roaming\ESRI\Desktop<version>\ArcMap

Replace with your ArcGis Desktop version.

You don't need to put the toolbox in your 'my toolboxes' folder to add to the default but the toolbox must be in a stable location i.e. not on a USB stick; if the toolbox isn't found at startup it will be removed and may not reappear when the resource becomes available.

Open the toolbox Geoprocessing::Toolbox then right click on the root node and select 'add toolbox', browse to your toolbox and add it. After the toolbox is added right click on the root node again and select Save Settings::To Default which will write the new settings to your Normal (gxt or mxt).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.