1

Linux Mint 17.2 Just came to fire up QGIS after a couple of days doing other stuff and the launcher is not on my panel and the program is not listed in the Applications menu.

Presumably something I have done has removed it, but there is still a directory .qgis2 in my user directory. I've looked in various places and can't see any QGIS-related stuff.

I had been (having trouble with) installing LAMP and related stuff, which I uninstalled & installed XAMPP. The only system change I can think of is the LAMP uninstall removed QGIS? This is the command I used:

for pkg in dpkg -l *apache* *mysql* phpmyadmin | grep ^ii | awk '{ print $2 }'; do sudo apt-get -y purge --auto-remove $pkg; done;

Any ideas? Any log that I can see what might have happened?

  • 2
    Have you tried re-installing? Obvoiusly your command deleted too much packages. – AndreJ Mar 15 '17 at 12:12
  • Maybe the Apache2 in LAMP is used for qgis-server package. – luca76 Mar 15 '17 at 12:15
  • what does apt-cache policy qgis return? – dmci Mar 15 '17 at 12:22
  • dcmi this. Even to me it doesn't look good... 'code' qgis: Installed: (none) Candidate: 2.14.3+dfsg-2~trusty1 Version table: 2.14.3+dfsg-2~trusty1 0 500 ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu trusty/main amd64 Packages 2.0.1-2build2 0 500 archive.ubuntu.com/ubuntu trusty/universe amd64 Packages 500 archive.ubuntu.com/ubuntu trusty-updates/universe amd64 Pack ,'code' – user3418765 Mar 15 '17 at 13:39
  • AndreJ, not yet. probably will have to but hoping I can reinstate the packages. This was the first time (on Linux) that I had the GRASS & SAGA tools working -all my previous Lx installations over the years never worked, only on W7. I had been hoping to defer the pain until QGIS 3 comes out. – user3418765 Mar 15 '17 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.