1

I am attempting to change the default cache directory for ArcMap so that when I publish a service I can cache its tiles on an alternative drive to Local Disk due to insufficient memory issues. However when I tried to do this using ArcGIS Server Manager I encountered the following error:

Failed to register the server directory 'MIPCache'. Cannot write to directory path 'Z:'. Please check that the location is valid and that the ArcGIS Server account has permissions to the location.

Please note that permission should be in place, that I can manually access the folder location and that the user carrying out this process is the same one as the user that installed ArcMap on the server.

I am at a roadblock and have no idea what may be wrong...

  • You seem to be confused by the fact that ArcGIS Desktop and ArcGIS Server are different software packages. Changing the default cache directory in ArcMap has no impact on ArcGIS Server. You don't have "memory issues" but disk issues. ArcGIS Server cache should always be on a local disk, not a network volume. The user that installed Desktop has no bearing on the user that owns the Server processes. You'll need to provide more details on how you installed Server before we can help you. – Vince Mar 16 '17 at 12:20
  • I stated that I needed to change the directory FOR Arcmap, and this is done through arcgis server manager by adding a new directory. Currently the default cache directory is on the server's local disk, however since the map service that I am trying to cache will exceed 1TB of data another drive was mapped to the server which would have sufficient storage to hold this data. However when I try to create a new directory on the drive using arcgis server manager I get the above error. I have seen examples where people have multiple cache directories on multiple drives but for me it isn't working. – Maeglin77 Mar 16 '17 at 13:39
  • Maeglin77 An ArcGIS Server cache should be local to the server, not a mapped network drive. I also think it would be good to edit your question and remove references to ArcMap, as it should have no bearing on the issue as @Vince has commented already. – Midavalo Mar 16 '17 at 15:19
  • If you do still want to continue caching over the network, the error message appears to be that the ArcGIS Server doesn't have permissions to write to the new location. Remember this is likely to be a different user account. – Midavalo Mar 16 '17 at 15:20
  • I have tried for multiple users for multiple accounts, and the drive was given permission of full control for all users and full control was even given to the server machine however the same error is still persisting, that is why I am at a roadblock. – Maeglin77 Mar 30 '17 at 10:05
2

The issue actually is related to permissions. Since the drive being used is a networked drive a user account had to be created on the drive with the same username and password as those used for the installation(not server manager login account) of arcgis server on the desktop. The path to the cache directory was then given using the drive ip address instead of the drive letter and caching was carried out successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.