1

I have downloaded FnodeTnode Tracer plugin from Pitney Bowes plugins repository website. It was just the MBX file that I have to regester it into my MIPRO and did it.

I have water distribution network with different levels of data. Now, I wanted to Trace the Water network End to end. I have selected one link out of networking and I have selected one link from the network and Clicket Strat Tracing. But, I was not lucky to get the tracing done. I have Fnode and Tnode in the Network layer table

Here is the Network layer which has Fnode and Tnode Columns. I have used LineTopo.MBX file which is suggested by @sys49152 enter image description here

Here is the Node file which is populated fter using LineTopo.MBX

Node File

Then I have selelectd one of the link in Network Layer and clicked on Start tracing enter image description here

I have Got this error, But Tracing dint happen.

enter image description here

Process Summary : I have just used Linetopo.MBX for creating Nodes and Node ID's then i moved Node layer to cosmetic layer along with Network layer and clicked on FNode Tnode Trace.

How do I achieve Tracing Upstream and Downstream?

I have few other Point features and Line features in my Water network.

1

NOTE: To be eligible for tracing, the network table MUST contain previously populated FNODE and TNODE columns. This application cannot build FNODE-TNODE topology.

Well, that's the catch. Before using this tool you should prepare new 2 columns (FNODE and TNODE) in your network layer which should be populated with FromNode, ToNode (or StartNode, EndNode) values.

But, before that, you will also need "nodes" with enumeration to know which node represent the starting point and which node is the end of your geometry object.

enter image description here

So, for that, you should create starting and ending points of your lines and polylines from your network geometry layer into a separate point layer.

After creation of layer with nodes/points with their respective ID numbers, you should populate FNODE and TNODE fields in network layer with those ID values.


LineTopo.MBX is a little MapBasic utility that could do this task.

  1. Load this tool and it will show up as NetworkAnalyst menu in MapInfo

enter image description here

  1. Open menu and start Build Line Topology.... Choose a table with your line dataset.

enter image description here

  1. Wait til is finished.

enter image description here

  • As a final result tool will create point layer with ID attribute and it will add two new columns _From_Node_ and _To_Node_ into selected network layer.
  • Rename those new columns into FNode and TNode
  • Now you can try FnodeTnode Tracer plugin
  • Thanks for the Provided solution. I am a big time underdog in MapInfo. It would be grateful if you can explain on population FNODE and TNODE in network layers with ID values. I have about 600 small line features which are connected in the network. I have generated the Nodes it has saved in different TAB file. Then I have added FNode and T node columns in Network Tab file. I have select one feature and clicked on Trace and selected Upstream trace but the results are not as expected. The Entire network has been selected. – Bunny Chowdary Mar 17 '17 at 11:12
  • I wanted to do Upstream/ Downstream tracing, It should show the entire flow from Delivery point to the Distribution Point. For example, if there are devices in the flow then the device should be highlighted. Please guide me to achieve this. I have not kept any values in F node and T node column. Still, the entire network has been highlighted. I would be very much delighted if you can advice me with the step by step guide to achieve this Tracing in Mapinfo – Bunny Chowdary Mar 17 '17 at 11:16
  • I have updated an answer. Please upvote and accept it if this solves your problem – sys49152 Mar 17 '17 at 11:49
  • I am still unable to do the Upstreaming using LineTopo.MBX. It would be grateful if you can show the step by step procedure. As of I know most of the MapInfo users are struggling to get this Tracing job done. – Bunny Chowdary Mar 17 '17 at 12:35
  • I just tried and it works. What is exactly your problem ? Please give us a more detail. – sys49152 Mar 17 '17 at 12:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.