4

A similar question was asked as Getting more details by zooming in web-client? but the answer did not work for me. Unfortunately, I can't comment there due to being new to GIS.SE.

Background: The QGIS project has a WMTS service layer of drone aerial imagery (from mbtiles). The Desktop QGIS displays this layer perfectly and lets me zoom in to see the higher resolution of the tiles.

The drone imagery displays OK in QWC but does not let me zoom any closer than 1:2257. The (original desktop) project CRS is EPSG::3857 and in the Desktop project settings>OWS Server>CRS Restrictions is set to EPSG::3857 as the first entry. This .qgs project file was copied to the server and displays OK.

I changed in GlobalOptions.js this

var MapOptions = {
  projection: new OpenLayers.Projection(authid),
  units: "m",
  maxScale:250,
  minScale:80000,
  numZoomLevels:ZOOM_LEVELS,
  fractionalZoom: !enableWmtsBaseLayers && !enableBGMaps,
  transitionEffect:"resize",
  controls: []
};

I cleared the browser cache and refreshed the QWC but the zoom function is still maxed at 1:2257.

I also tried changing in OpenLayers.js: numZoomLevels from 16 to 22.

None of these attempts has changed anything in the QWC.

How do I zoom in more (as there is more detail to see in the drone imagery)?

  • Hello and welcome to GIS SE, could you try adding some different kind of data to a project, for example a shp file and try the zooming. I think the problem could lie with the tiles. – Piskr Mar 17 '17 at 18:50
  • Thank you. I removed the tile layer and just left a shp layer but the zoom is still maxed at 1:2257. If the tile layer was at fault then zooming it in QGIS desktop would have produces the same zoom restriction...which it doesn't. Is the overall zooming restricted by the base layers? heritageni.com/demo/QGIS/site/qgiswebclient.html?map=/home/… – Irishsights Mar 18 '17 at 18:31
  • Yes that could actually be the case. You could try disabling the default maps as described here: gis.stackexchange.com/questions/126904/… And then try again – Piskr Mar 18 '17 at 19:29
2

In GlobalOptions.js setting

var enableOSMMaps = false; 

and enabling

var enableGoogleCommercialMaps = true;

Allowed me to zoom into 1:282

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.