1

Im trying to readout the data from my ublox LEA-6H recever over RTKLIB's str2str command-line user interface (CUI). Im using rtkkib_2.4.2 on ubuntu 16.04.02 and the ublox receiver is connected over usb. im trying the following

sudo ./str2str -in serial://ttyUSB0:38400#ubx –out file://~/test.txt#ubx

i get the errormsg:

specify output stream(s)

how can i understand the documentation of rtklib. it says the following: rtklib2.4.2-doc

1 Answer 1

1

Your shell is possibly interpreting the hashes in your command as comments. This might work better:

./str2str -in 'serial://ttyUSB0:38400#ubx'  ...

Also - are you using the right device specification? Additionally, using ~ with sudo might be problematic. Add yourself to the dialout group (or whatever group /dev/ttyUSB0 belongs to) so you can access the serial port without elevated privileges.

5
  • Checked if i'm a member of dialout and tried: sudo ./str2str -in 'file:///dev/ttyUSB0:38400#ubx' –out 'file:///home/user/testlog.ubx' but i'm getting still the same error
    – Rud Qertz
    Mar 18, 2017 at 13:33
  • 1
    why are you still using sudo? You don't need to if your user is a member of dialout. The file:// specifications look redundant, so how about: ./str2str -in 'serial:///dev/ttyUSB0:38400#ubx' -out ~/testlog.ubx
    – scruss
    Mar 18, 2017 at 13:38
  • it still throws: specify output stream(s)
    – Rud Qertz
    Mar 20, 2017 at 10:17
  • sounds like it's very picky with command type and order. Ask here: str2, and see if anyone else has repeated the problem here: RTKLIB
    – scruss
    Mar 21, 2017 at 1:17
  • Try ./str2str -in serial://ttyUSB0:38400#ubx –out /home/user/test.ubx Also maybe try cat /dev/ttyUSB0 to test you have working permissions. I use a line like this in a script: str2str -in serial://ttyACM0:230400#ubx -out /home/pi/GPS/log/rover.ubx -out tcpsvr://:1888 -c /home/pi/GPS/m8t_5hz_usb.cmd
    – Dave X
    Dec 20, 2017 at 2:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.