I am trying to import a WFS layer into QGIS. I tried the normal procedure, Add WFS Layer, and it does not display any boxes. When I click on Add, it throws an error:

Layer is not valid: The layer restrictToRequestBBOX='1' srsname='EPSG:4326' typename='bu:Building' url='http://ovc.catastro.meh.es/INSPIRE/wfsBU.aspx' version='auto' table="" sql= nis not valid and cannot be added to the map

I also tried the WFS 2.0 Plugin and in this case, I was able to download some vectorial data which seemed to be ok, but only if I was zooming very close to extract some features. When I zoom out to get the extent I need (or even a bit more), I get the following error:

ows error

OWS Exception returned from the WFS: Area of extension out of limits.

However, I know there is data beyond my bounding box.

Am I doing something wrong? I also changed the EPSG several times and it did not work either.

1 Answer 1


According to this service description of the WFS the following rules apply to the usage of the service:

Limitaciones del servicio WFS:

  • Búsqueda por caja de 4km2 y 5.000 elementos
  • […]

Translated via Google Translate it means:

WFS Service Limitations:

  • Search by box of 4km2 and 5,000 elements
  • […]

This means, that the extension for a single request from the client is restricted to an area of not more than 4 km², which explains your described behaviour.

  • Well, that makes a lot of sense then. Thanks a lot!
    – illpack
    Mar 20, 2017 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.