0

I have added MBTiles plugin to my GeoServer in order to generate my maps in .mbtiles format, so I can read maps in offline mode.

My problem is that, when I preview my maps in GeoServer, it includes all zoom levels, but once I downloaded .mbtile file I found that it contains only zoom levels from 1 to 5. And when I changed the EPSG:4326 to EPSG:3857 it doesn't work but when I opened the .mbtiles file from dbBrowser for SQLite 3 I found that it contains another range of zoom levels: this time from 19 to 21.

The request is:

http://localhost:8080/geoserver/wms?request=GetMap&service=WMS&version=1.1.1&layers=mdintimaps:test&styles=&srs=EPSG%3A4326&bbox=-76.962,-76.735,120.066,69.01&width=768&height=568&format=mbtiles

Any help?

1

According to the documentation you should specify the min and max zoom levels desired, otherwise the output format will make a best guess as to which zoom levels to return in order to respond quickly (a WMS request is synchronous).

However, if you want to generate many zoom levels, best to make a asynchronous WPS request instead, a WMS one will likely time out before it completes. You can use the WPS request demo builder to set up a rough template, and then modify it to be asynchronous

  • 1
    I appreciate all of your help, i found the zoom levels in the documentation but i was doing it in the wrong way, i wasn't specifying the format_options parameter. I was specifying max_zoom directly in the url so the correct one should be this way: [localhost:8080/geoserver/… But the result of mbtiles is about 1gb. Thank you so much for your help – Othmane_lam Mar 23 '17 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.