6

Linux Mint 17.2. After trying to reinstall QGIS through various processes referred to on SE, AskUbuntu & anywhere else*, I get various unmet dependency or held broken packages errors.

Even with adjusting the repository details from saucy or xenial to trusty etc, I still can't get anywhere.

I have had this message a number of times:

The following packages have unmet dependencies.
 qgis : Depends: qgis-providers (= 2.14.3+dfsg-2~trusty1) but it is not going to be installed

I can't find out what this means to rectify it - anything I've followed up hasn't worked.

I am trying to install QGIS 2.18 with GRASS.

Can someone help?

*eg: Broken packages and unmet dependency installation QGIS, PostgreSQL and postgis Ubuntu 14.04

QGIS install on Ubuntu 14.04 fails

https://askubuntu.com/questions/351899/qgis-quantum-gis-install-fails-unmet-dependencies

4

According to https://launchpad.net/~ubuntugis/+archive/ubuntu/ubuntugis-unstable/+index?field.series_filter=trusty, the QGIS package you have loaded is from the ubuntugis unstable ppa. This version is slightly outdated by now.

If you use the qgis.org/ubuntugis repo, you can have the latest QGIS 2.18.4 by adding to your repo list:

deb http://qgis.org/ubuntugis trusty main
deb-src http://qgis.org/ubuntugis trusty main

If you want to stick to the LTR version, qgis.org/ubuntugis-ltr offers now QGIS 2.14.12 by adding

deb http://qgis.org/ubuntugis-ltr trusty main
deb-src http://qgis.org/ubuntugis-ltr trusty main

In any case, stick to the Ubuntu dist version you are running (i.e. trusty), and update and upgrade all other packages before updating QGIS with

sudo apt-get update
sudo apt-get upgrade

You might as well have to upgrade the keys for QGIS and ubuntugis.

If you decide to switch from ubuntugis to non-ubuntugis repos, make sure to clean and purge anything related to QGIS.

  • In the end, I managed to purge enough to make it work. As a lot of people have this problem, is there nowhere to put a guide to uninstalling what you've already got? (ideally on the QGIS site with the installation instructions) as the official instructions don't cover this just "Please remove all the QGIS and GRASS packages you may have installed from other repositories before doing the update." - the purge commands would be helpful. – user3418765 Mar 21 '17 at 17:50
  • GRASS tools are showing & GRASS 7 shows as activated in the Providers menu but I get the "Missing dependency, GRASS isn't configured properly" message. How do I configure it properly? – user3418765 Mar 22 '17 at 9:23
  • @user3418765 this is worth a new question, adding some more details. Can you run GRASS without QGIS? Did you run GRASS or GRASS7 algorithms? The first would expect GRASS v6. – AndreJ Mar 22 '17 at 10:04
5

Got this problem a long time ago on Ubuntu.

Now I'm using Mint and I've installed QGIS without any problems with:

# add-apt-repository ppa:ubuntugis/ubuntugis-unstable

# nano /etc/apt/sources.list

Edit sources list and add two lines:

deb http://qgis.org/ubuntugis xenial main
deb-src http://qgis.org/ubuntugis xenial main

Update and install QGIS:

# apt-get update

# apt-get install qgis

Before you try, please purge your current QGIS installation.

  • How to purge? If I run "sudo apt-get purge qgis" , I get "Package 'qgis' is not installed, so not removed" Am I missing something? – user3418765 Mar 20 '17 at 22:29
  • 1
    I'm still on trusty, so i should edit ubuntugis xenial main to trusty? – user3418765 Mar 20 '17 at 22:34
  • 1
    That might be it. The QGIS instructions suggest to me that you put your current version in thus deb *repository* *codename* main – user3418765 Mar 20 '17 at 22:39
  • 1
    How attached are you to your Ubuntu install? Might be time to reinstall. That said, I think you should be using Trusty if your core OS is Trusty. You should be able to remove all your repos and do 'apt-get -f install' to get to a clean place. – Alex Leith Mar 21 '17 at 0:26
  • 1
    Finally worked, using add-apt-repository ppa:ubuntugis/ubuntugis-unstable then apt-get update # apt-get install qgis apt-get update # apt-get install qgis apt-get update # apt-get install qgis sudo apt-get install qgis python-qgis qgis-plugin-grass – user3418765 Mar 21 '17 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.