I am using ArcGIS Pro 1.4 on a laptop with the following specs:

  • Windows 10 Home 64-bit
  • Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
  • Memory:16 GB @ 1200 MHz
  • NVIDIA GeForce GTX 1060, 6144 MB (Just updated the driver)

The Shapefile I am trying to display is linked here: TM_WORLD_BORDERS_SIMPL-0.3.zip

When I open in Desktop 10.4 it dispalys fine but in Pro I cannot see the layer. I can access the attribute table and the information function works just fine.

ArcGIS Pro 1.4 Pro_1.4

ArcGIS Desktop 10.4 Desktop_10.4

Has anyone else experienced anything like this?


3 Answers 3


Your shapefile name has a . character in it. This is invalid.

The shapefile specification says file names must start with an alphanumeric character (a–Z, 0–9) and can only contain the characters (a–Z, 0–9, _, -).

  • answer below shows that it's this one is not a correct answer, so please change it Apr 21 at 18:27

I found why your data didn't displaying on ArcGIS Pro. Your Shapefile name contains special character(-). Rename your shapefile(dbf,prj,shx,shp) name on Windows Explore. It will be opened in ArcGIS Pro.

  • Thanks for this, a shapefile of mine wouldn't display until I removed a full stop from it's filename. Which is utterly insane... Apr 9, 2019 at 8:59

I recently came across this same problem with ArcGIS Pro. A shapefile wouldn't display but would open perfectly fine in both Global Mapper and QGIS. None of the solutions here or elsewhere (e.g. renaming the file, using geometry fixer) worked.

I simply converted the file to GeoJSON in Global Mapper (I assume you could use QGIS too) and converted it back to a shapefile in ArcGIS Pro using the GSON to Features tool. Problem solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.