0

I am geocoding some addresses and it works just fine. However, all the points are rearranged afterwords. How can I stop it from rearranging the points? Is this a locator issue?

Geoprocessor GP = new Geoprocessor();
            GeocodeAddresses geocodeAddresses = new GeocodeAddresses();
            geocodeAddresses.in_table = workSpaceLocation + "\\" + addressTable;
            geocodeAddresses.address_locator = addressLocator;
            geocodeAddresses.in_address_fields = "Street Address;" +
               "City <None>;" + "State <None>;" +
               "ZIP <None>";
            geocodeAddresses.out_feature_class = workSpaceLocation + "\\" + outputFeatureClass;
            geocodeAddresses.out_relationship_type = "STATIC";

                IGeoProcessorResult result = GP.Execute(geocodeAddresses, null) as
                    IGeoProcessorResult;
                if (result != null)
                {
                    if (result.Status != esriJobStatus.esriJobSucceeded)
                        MessageBox.Show("Failed to Geocode.", "Error", MessageBoxButtons.OK, MessageBoxIcon.Error);

                }
                else
                {
                    MessageBox.Show("Failed to Geocode.", "Error", MessageBoxButtons.OK, MessageBoxIcon.Error);
                }
0

I found the answer to this by looking at the Locator Properties. There is a setting called "Presort input table by (fields)". This should not have any fields selected if you do not want your points to be rearranged.

Locator Properties

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.