1

I´m using GeoServer where I can query WMS services to get image from a CQL Filter query. The URL for the service looks like:

http://myserver/ows/LIMITS_ADM/wms?LAYERS=LIMADM_MUNICIPI&TRANSPARENT=true&FORMAT=image%2Fpng&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&SRS=EPSG%3A25831&CQL_FILTER=(NOM_MUNI%20ILIKE%20%27%25%C3%80ger%25%27%20OR%20NOM_MUNI%20IS%20NULL%20)&BBOX=153185.99759615,4418250,640814.00240385,4818750&WIDTH=1519&HEIGHT=1248

If I run debug on Chrome I get the following:

1. Headers Headersview source:

1.1.    Request URL:
http://myserver/ows/LIMITS_ADM/wms?LAYERS=LIMADM_MUNICIPI&TRANSPARENT=true&FORMAT=image%2Fpng&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&SRS=EPSG%3A25831&CQL_FILTER=(NOM_MUNI%20ILIKE%20%27%25%C3%80ger%25%27%20OR%20NOM_MUNI%20IS%20NULL%20)&BBOX=153185.99759615,4418250,640814.00240385,4818750&WIDTH=1519&HEIGHT=1248

1.2.    Request Method: GET

1.3.    Status Code: 200 OK

1.4.    Remote Address: myserver:80


2.  Response Headersview source

2.1.    Connection: close

2.2.    Content-Disposition: inline; filename=LIMITS_ADM-LIMADM_MUNICIPI.png

2.3.    Content-Type: image/png

2.4.    Date: Wed, 22 Mar 2017 11:52:07 GMT

2.5.    HTTP_GICAR: CODIINTERN=NRDRJN0001;NIF=46335340T;EMAIL=nuria.majo@gencat.cat;UNITAT_MAJOR=CTTI;UNITAT_MENOR=CTTI Qualitat

2.6.    Server: Apache-Coyote/1.1

2.7.    Transfer-Encoding: chunked

2.8.    Via: 1.1 giscorp.sitep.com

3.  Request Headersview source

3.1.    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8

3.2.    Accept-Encoding: gzip, deflate, sdch

3.3.    Accept-Language: es-ES,es;q=0.8

3.4.    Authorization: Digest username="XXXXXXX", realm="XXXXXXXX", nonce="MgeAXFBLBQA=1e5891f56cbbe98d13a8861bfca9c2389a1aaaaa", uri="/ows/LIMITS_ADM/wms?LAYERS=LIMADM_MUNICIPI&TRANSPARENT=true&FORMAT=image%2Fpng&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&SRS=EPSG%3A25831&CQL_FILTER=(NOM_MUNI%20ILIKE%20%27%25%C3%80ger%25%27%20OR%20NOM_MUNI%20IS%20NULL%20)&BBOX=153185.99759615,4418250,640814.00240385,4818750&WIDTH=1519&HEIGHT=1248", algorithm=MD5, response="4ca4bf17a155b05c43d2427dd315fd35", qop=auth, nc=00000002, cnonce="72bfb7cba5bac55b"

3.5.    Cache-Control: max-age=0

3.6.    Connection: keep-alive

3.7.    Cookie: XXXXXX; XXXXXX=ca-ES

3.8.    Host: myservice

3.9.    Upgrade-Insecure-Requests:1

3.10.   User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/56.0.2924.87 Safari/537.36


4.  Query String Parametersview sourceview URL encoded

4.1.    LAYERS: LIMADM_MUNICIPI

4.2.    TRANSPARENT: true

4.3.    FORMAT: image/png

4.4.    SERVICE: WMS

4.5.    VERSION: 1.1.1

4.6.    REQUEST: GetMap

4.7.    STYLES: 

4.8.    SRS: EPSG:25831

4.9.    CQL_FILTER: (NOM_MUNI ILIKE '%Àger%' OR NOM_MUNI IS NULL )

4.10.   BBOX: 153185.99759615,4418250,640814.00240385,4818750

4.11.   WIDTH: 1519

4.12.   HEIGHT: 1248

The response returns an empty image. If I change the cql filter with no diacritic character, it does return an image.

My question is:

  1. Is there a way that I can use diacritic on cql filter?
  2. Is there a way that I can include a header with content type = application/x-www-form-urlencoded;charset=UTF-8?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.