I have a DEM of Saint Lucia, obtained from the CHARIM database. It is a large geotiff (150MB), and I would like to crop it as I only need a small part of it. I have been trying to use Raster -> Extraction -> Clipper in QGIS, but it fails because it says I need thousands of TB of disk space to complete the operation. From reading around, I presume that this is because the file is already compressed, however I don't really know how to go about solving it.

This is the layer metadata:

GDAL provider
Dataset Description
/Users/cameron/Desktop/Design IV/St Lucia GIS/topography.tiff
Band 1
X: 4536 Y: 8763 Bands: 1
Pixel Size
No Data Value
Data Type
Float32 - Thirty two bit floating point 
Pyramid overviews
Layer Spatial Reference System
+proj=longlat +datum=WGS84 +no_defs
Layer Extent (layer original source projection)
-61.0812601912316993,13.7067470580471564 : -60.8717473436720837,14.1115003832598784
Band 1
Band No
No Stats
No stats collected yet 

Can anyone tell me what I should be doing instead? I am relatively new to GIS and this is the first thing I have come across that I can't immediately find my way around.

EDIT: The Clipper settings are as follows:

gdal_translate -projwin 507118.619912 1549423.97735 511757.851837 1546542.77015 -of GTiff

And the error log:

Warning 1: Computed -srcwin 1.09806e+10 -3.35451e+10 1.0044e+08 6.23788e+07 falls completely outside raster extent. Going on however.
ERROR 3: Free disk space available is 8291942400 bytes, whereas 25061401106245716 are at least necessary.`
  • 1
    Can you edit your answer and post a Clipper settings you used?
    – Oto Kaláb
    Mar 22, 2017 at 14:13
  • The first thing I would do is assign a projected CRS rather than a geographic one. I'm not familiar with the area so I can't recommend a proper CRS but with some digging around you should be able to find the right one to use.
    – Techie_Gus
    Mar 22, 2017 at 15:21
  • I have the same problem currently and the same error. I tried re-projecting the raster, but this didnt help to solve it. Any other ideas? ![enter image description here](i.stack.imgur.com/t5ZhW.png) Jul 18, 2018 at 11:15
  • I solved it by using qgis tool "clip raster by polygon". Jul 18, 2018 at 11:49
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review
    – nmtoken
    Sep 25, 2018 at 14:36

2 Answers 2


The problem is in your input extent, you defining extent from other CRS so the Clipper trying clip the:

-61.0812601912316993,13.7067470580471564 : 60.8717473436720837,14.1115003832598784


507118.619912,1549423.97735 : 511757.851837,1546542.77015

Which makes raster much bigger ("thousands of TB") than base raster 150MB

You have to reproject your input raster to CRS you are using, or in clipper extent use EPSG:4326 (+proj=longlat +datum=WGS84 +no_defs) coordinates.

Layer Spatial Reference System
+proj=longlat +datum=WGS84 +no_defs
Layer Extent (layer original source projection)
-61.0812601912316993,13.7067470580471564 : -60.8717473436720837,14.1115003832598784

Your raster is in longitude-latitude coordinates, but you are trying to clip it using UTM coordinates, so you're actually creating a much larger raster, rather than cropping it into something smaller. You have two choices: use lat-long coordinates in the clipper, or reproject the raster to the utm coordinate system of your choice using the Warp(Reproject) tool under the raster menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.