3

I am trying to publish a very large raster data set, ~330GB. I get the general error: "Packaging succeeded but publishing failed"

The geoprocessing results say to check the server logs.

The server logs provide general error messages:

  • Failed to construct instance of service 'TestBrandon/ImgTest_321.MapServer'. Service startup timeout.
  • Core server call to create service failed (/admin/createService).
  • Failed to create the service.: ERROR: Service failed to start,
    Internal server error.
  • Error executing tool. PublishServiceDefinition Job ID:
    j360531ad8cd940a490f8f7ee2085dc49 : ERROR 001369: Failed to create
    the service. Failed to execute (Publish Service Definition).
  • The service 'TestBrandon/ImgTest_321.MapServer' was not found.
    Verify the service exists and is started.

There is nothing wrong with my configuration settings; I am able to publish if I only do half of the tiles. It is also not corrupt data because I successfully published both halves of the data set.

It also has nothing to do with the cache, because I have it set to manually build cache afterwards (and I can publish with building cache when I only publish half of the tiles).

I do have a lot of .SOC processes running on the server machine, but I tried stopping all of them during after-hours with no luck.

It seems like it is stemming from the first error message: "Service startup timeout"

I'm guessing it is just taking too long with the large data set. Is there anyway I can increase this time so it does not timeout?

Running ArcMap 10.4.1

  • 3
    This is possibly something that should go direct to Esri or local support – Midavalo Mar 22 '17 at 21:31
  • I have been in contact with Esri, they have no idea. – Brandon G. Mar 22 '17 at 21:32
  • 1
    You can try increasing the time outs on the publishing service. I hope in this case you have a datastore reference set and you're not really moving 300gb of files from your client to the server. Thats just my personal opinion, you can do it if you want..... – KHibma Mar 22 '17 at 21:51
  • Yes, I have the data registered and am not moving the data to the server. I have also tried increasing these publishing properties: "The maximum time a client can use a service" and "The maximum time a client will wait to get a service" to essentially unlimited time. – Brandon G. Mar 22 '17 at 21:53
  • Sometimes this can mean a net-bot is killing long-running network connections. – Vince Mar 22 '17 at 23:12
2

The problem was that I had to change the permission level on the "python27" folder on the C:\ drive of our publishing machine. The ArcGIS Server user account did not have full permissions. Giving it full permissions allowed it to successfully publish.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.