I am trying to calculate the areas of administrative regions in Uganda, using the EPSG:102022 projection. They are polygons. But everything I do produces areas in degrees rather than meters, giving results with small decimal values. I'm using QGIS 2.18 on a Mac. It should be so simple, but I'm at my wit's end. Does anyone know the secret?

I have tried:
-Using Vector/Geometry Tools/AddGeometryColumns and $area in fieldcalculator
-Using Layer and Project CRS
-Turning off on-the-fly re-projection
-Turning off the Render toggle
-Saving and loading new .shp files with the EPSG:102022 projection
-Changing all the defaults in Settings/Options/CRS to EPSG:102022
-Running Singlepart to Multipart and the reverse
-Updating QGIS
-Restarting my computer

There have been many similar questions posted, and none of the answers or comments in them are working for me: Area is calculating wrong using $area in field calculator (QGIS 2.8.1-Wien) How to calculate polygon areas in QGIS?

In case you want the file: https://drive.google.com/file/d/0B5fZYKTx5SCbWmFuQkVpYVBXbFU/view?usp=sharing

  • Have you checked your polygon layer for invalid geometries, such as lines that cross, or duplicate nodes? The topology checker plugin will help you find issues, but you'll have to fix them manually.
    – csk
    Commented Mar 23, 2017 at 16:27
  • Another thing you could try: do the area calculation in a new QGIS project with no extra layers. Sometimes it seems that even with OTF reprojection turned off, the projections of other layers mess with the calculations. Especially if you have a baselayer like Google Maps that uses a pseudomercator projection.
    – csk
    Commented Mar 23, 2017 at 16:33
  • Welcome to GIS SE! As a new user please take the tour to learn about our focused Q&A format.
    – Midavalo
    Commented Mar 23, 2017 at 16:35
  • EPSG:102022 is not an official EPSG code but an ESRI code even sites like epsg.io/102022 seem to give wrong authority. You may need to add a custom projection to QGIS with the parameters that you find from the link before QGIS know what it is.
    – user30184
    Commented Mar 23, 2017 at 20:51
  • Thank you @csk I did have one small error in the geometry, but I am getting the same issue now that I have fixed it. Also for other shapefiles that I haven't modified at all. Commented Mar 23, 2017 at 22:52


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.