6

I downloaded and installed Quantum GIS 1.5.0 with GRASS using the OSGeo4W installer on my Windows XP machine. Unfortunately, when I go to Plugins>Manage Plugins I cannot find the GRASS plugin. When I browse to OSGeo4W\apps\qgis\plugins I can see grassplugin.dll, grassrasterprovider.dll and grassprovider.dll. So, I would appreciate it if someone could tell me how to make QGIS recognize the GRASS install.

  • Is GRASS itself installed via OSGeo4W? Do you see other plugins? – underdark Oct 1 '10 at 9:12
  • What do you see if you go to Plugins>GRASS? I see 4 plugins enabled, but the rest are grey'd-out. I haven't installed GRASS though. – DavidF Oct 1 '10 at 15:01
  • Hi jvangeld, we'll need further information from you in order to answer your question. – scw Oct 4 '10 at 17:59
  • 1
    David, I do not have an option for GRASS in my Plugins menu, and it does not show up in Manage Plugins... – jvangeld Oct 9 '10 at 0:29
  • 1
    New and related development: gis.stackexchange.com/a/319333/5256 – Nikos Alexandris Apr 19 at 11:07
5

I just installed QGIS 1.5.0 two days ago. The GRASS plugin shows up in my Plugin Manager and under the Plugin Menu. I used the Standalone Installer though, rather than the OSGeo4W Installer. You might want to try that route. (http://www.qgis.org/wiki/Download)

You also have to set up a GRASS Database through the "Plugins > Grass > New Mapset" menu in order to get the other GRASS Plugin Menu items to become active.

alt text

  • Thanks! That did it. Apparently there is some issue with the OSGeo4W installer and the GRASS plugin. – jvangeld Oct 9 '10 at 1:36
1

See also the draft "QGIS GRASS Cookbook" which is available here: http://grass.osgeo.org/wiki/QGIS_GRASS_Cookbook

In the long run it should go into the QGIS user manual as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.