6

I have shapefiles for multiple countries in Europe, with places as individual polygons in each file.

I want to use the field calculator to add a column for each polygon's area, but every time I run the "$area" calculation the number returned is much less than it should be. They are typically off by two orders of magnitude.

I have put these files in every equal area projection I can think of (focusing on ones that use meters as units instead of lat/long), and the numbers are still incorrect. This happens both with OTF enabled and disabled, and when the map units are in km and meters. I've also had this issue both when I define the project CRS or just the CRS for one layer.

I've tried:

-UTM (different zones for each country) EPSG:32231 and EPSG:32631
-EPSG:3408, NSIDC EASE-Grid North
-EPSG:2163 - US National Atlas Equal Area
-EPSG:53012 - Sphere_Eckert_IV
-ETRS89 LAEA (EPSG:3035)

  • Are the shapefiles displayed correctly in QGIS? Do they align for example with a web basemap? – Redoute Mar 23 '17 at 21:15
  • Good thinking. No, in any of the above projections they do not line up with the basemap. The only shapefiles that do line up are in EPSG:4326, WGS 84. – Ellory Mar 23 '17 at 22:26
9

If your layers don't line up with any base map, you have misused Define CRS of the layer.

You MUST set them back to the original CRS (or better take a fresh copy to start off), then reproject them using Save As ... to a different filename and the CRS you want.

  • This fixed it! I had been duplicating layers/changing the CRS of an existing layer in the properties window as opposed to saving new copies in a new projection. – Ellory Mar 24 '17 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.