1

I have a shapefile that looks like this:

I want to delete the holes, but I can't use any of the editing tools apparently...

What can I do?

  • 1
    Do you have a query applied to the layer? Check that layer's properties window in the General tab and see feature filter. Also another basic check is to make sure that layer is highlighted in the layer list. – SaultDon Mar 24 '17 at 21:20
  • @SaultDon Yes, I have it on purpose. So I could delete the small polygons. – dari1495 Mar 24 '17 at 21:26
  • Editing doesn't work with a feature filter =) You can maybe select those features instead (copy and paste your feature filter). Editing usually only edits the selected features. – SaultDon Mar 24 '17 at 21:31
  • Yeah I saved as a different shapefile before editing – dari1495 Mar 24 '17 at 22:31
4

Turn on the advanced digitizing toolbar - View > Toolbars

Then use the delete ring feature.

  • It's the same, there are more buttons but I cannot use them picture – dari1495 Mar 24 '17 at 21:24
  • Have you made the layer editable? Click on the pencil icon to 'Toggle Editing' if you haven't. – Martin Hügi Mar 24 '17 at 21:27
  • And as SaultDon says, make sure the layer is highlighted in your layer list. – Martin Hügi Mar 24 '17 at 21:28
1

Looks like you have a feature filter applied. Editing doesn't work like that in QGIS so maybe consider using that feature filter and applying it as a selection.

This would require you to remove the feature filter, but editing should only apply to selected features.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.