12

After updating to QGIS 2.18.5 using ubuntugis ppa my QGIS 2.18.4 installation was removed and I get an error about unmet dependencies when I try to install QGIS at the terminal:

The following packages have unmet dependencies:
python-qgis : Depends: python-future but it is not installable
E: Unable to correct problems, you have held broken packages.

I have seen similar posts like this and this on SE, but they were not able to resolve my issue. I have python-future installed in python 2.7, but I still cannot install QGIS. How might I resolve this problem? I have also tried installing the LTR, but this results in an even longer list of unmet dependencies. My OS is Linux Mint 17.3 (Ubuntu 14.04).

  • 2
    This is also a problem for me on Mint 18.1. It appears to relate to the gdal-abi-2-1-2 package. I think this relates to the most recent qgis update not having been compiled against the most recent gdal update in the ubuntu repos. My only solution way to get a working version of qgis was to revert to an older version of qgis (see the reply from @Raja here gis.stackexchange.com/questions/217727/…) and update your sources.list to point to the nightly updates in the hope the developers sort the issue quickly. – scabecks Mar 27 '17 at 7:36
  • The same problem on Ubuntu 14.04 with qgis.org/debian ppa. – Oskars Mar 27 '17 at 8:54
  • Well...upgraded from 14.04 to 16.04. Everything is working. – Oskars Mar 27 '17 at 14:45
  • @AndreJ The Ubuntugis repo (current release) does indeed update to GDAL 2.1.3 just fine, but QGIS 2.18.5 (and several other associated packages) still fail because they depend on the virtual package gdal-abi-2-1-2, which isn't available. I'm stumped. – scabecks Mar 27 '17 at 21:21
  • I also don't have enough reputation to comment, but I have the exact same problem as @scabecks: Mint 18.1 with latest updates and Qgis.org and ubuntugis unstable repositories for xenial. QGis 2.18.5 complains about the package gdal-abi-2-1-2, which isn't available. Is there already a follow-up thread as requested by @AndreJ? – geotom Mar 29 '17 at 1:26
4

This is indeed a bug in the QGIS installer, and already has a ticket: http://hub.qgis.org/issues/16383

For the moment, only QGIS-LTR is running on trusty. You have to remove and purge the packages of QGIS 2.18 to avoid versioning conflicts: https://askubuntu.com/questions/187888/what-is-the-correct-way-to-completely-remove-an-application

Or consider upgrading to Linux Mint 18.1, which is based on xenial. The missing packages are available for that.

Installing python-future with pip does not help, since the package manager does not see that.


UPDATE

The ticket has been closed as fixed. Everything should be back to normal now.

  • 1
    You can also manually install python-future and python-owslib from packages.ubuntu.com/xenial/all/python-future/download and packages.ubuntu.com/xenial/all/python-owslib/download with dpkg, and then follow with upgrade. Note that those two packages will be left without updates (also security ones!) – pwes Mar 28 '17 at 9:20
  • But these are for xenial, not trusty. – AndreJ Mar 28 '17 at 9:26
  • It doesn't matter, as long as all of those packages' dependencies are met also in Trusty. – pwes Mar 29 '17 at 13:51
  • Following the instructions in the comment by pwes also did the trick for me on ubuntu 16.04 – wouterB Mar 29 '17 at 20:20
  • Anyway, the repos should be fine now. The newer version of python-qgis does not depend on python-future or python-owslib, so you can remove the "obsolete" packages I mentioned above. – pwes Mar 30 '17 at 7:35
1

Following the instructions in the comment by pwes:

You can also manually install python-future and python-owslib from http://packages.ubuntu.com/xenial/all/python-future/download and http://packages.ubuntu.com/xenial/all/python-owslib/download with dpkg, and then follow with upgrade. Note that those two packages will be left without updates (also security ones!)

I manually downloaded and installed the python-future package, and was able to install QGIS without a problem on my Mint 17.3 machine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.