12

I installed some python libraries using pip (pandas, scipy, simplekml) and ever since every time I try to load QGIS I get this error:

Warning: loading of qgis translation failed
[/usr/share/qgis/i18n//qgis_en_US]
Warning: loading of qt translation failed
[/usr/share/qt4/translations/qt_en_US]
Warning: QCss::Parser - Failed to load file  "/style.qss" 
Warning: QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action 
Warning: QVariantMap DBusMenuExporterDBus::getProperties(int, const QStringList&) const: Condition failed: action 
QH6248 qh_lib_check: Incorrect qhull library called.  Caller uses reentrant Qhull while library is non-reentrant
QH6249 qh_lib_check: Incorrect qhull library called.  Size of qhT for caller is 8184, but for library is 2896.
QH6255 qh_lib_check: Cannot continue.  Library 'qhull 7.2.0 (2015.2 2016/01/18)' uses a dynamic qhT via qh_QHpointer (e.g., qhull_p.so)

What is wrong? How can I fix it ? I have version 2.14. Should I remove it? Or maybe remove qhull library ?

  • hub.qgis.org/issues/5169 check this once – S. Thiyaku Mar 29 '17 at 16:18
  • This suggests to remove python qgis. I need it though – Stefanos Mar 29 '17 at 16:25
  • Try 'qgis --noplugins', if it starts then problem may be due to some plugin – S. Thiyaku Mar 29 '17 at 16:44
  • Can you add which Ubuntu version, and which QGIS repo you used? And maybe run apt-cache rdepends libqhull*.From the qgis/debian repo, I only get the third warning, and libqhull7. – AndreJ Mar 29 '17 at 16:45
  • Ubuntu version: 16.04 I installed from ubuntu gis repo (ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu) By running this command, I get a list of reverse depends. Which one is of interest ? I'm sure something happened yesterday that I installed these libraries..... :-( – Stefanos Mar 29 '17 at 17:02
21

Got the same problem on Linux Mint and finally fixed it.

The problem is that you've installed a few python libraries and one of them is a dependency of QGIS.

QGIS ~2.18 works fine with Scipy 0.17, and after upgrade this library to the newest version you have 0.19.

QGIS won't load with 0.19 because libqhull error.

All you need to do is downgrade, simply:

pip install scipy==0.17

And everything should be ok. You can also try with newer version but I'm not sure which one is good. I downgraded to 0.11 and it works form me again.

  • The main Ubuntu repo has python-scipy version 0.17.0 for xenial, if you prefer using packages instead of pip. – AndreJ Mar 29 '17 at 19:33
  • Dude...!!! You saved me..! I downgraded and it works. Although on startup QGIS shows a message that a plugin has been disabled due to last crash. Thanks ^_^ @AndreJ You mean instead of pip I should be using synaptic? – Stefanos Mar 29 '17 at 19:36
  • Synaptic or sudo apt-get install. It works better with QGIS and GDAL packages. – AndreJ Mar 29 '17 at 19:37
  • 1
    You can always use virtualenv docs.python-guide.org/en/latest/dev/virtualenvs – dmh126 Mar 29 '17 at 19:37
  • 2
    scipy==0.17 seems to be the newest version that works with QGIS 2.14 – leo Aug 26 '17 at 16:09
2

The same problem was pestering my QGIS on Fedora 27 for some time. QGIS was working fine, but if I wanted to install qgis-python, the libqhull error has prevented QGIS to start.

I did an ugly trick with compiling libqhull from the source and just overwrote the /usr/lib64/libqhull.so.7.2.0 with the manually compiled version and the problem was gone. The whole procedure was like:

  1. Install qgis-devel

    dnf install qgis-devel
    

    (so the QGIS is broken and can not start)

  2. Download qhull source, compile and overwrite the libqhull library

    cd /usr/local/src
    wget http://www.qhull.org/download/qhull-2015-src-7.2.0.tgz
    tar xzvf qhull-2015-src-7.2.0.tgz
    cd qhull-2015.2
    make
    cp -p lib/libqhull_r.so.7.2.0 /usr/lib64/libqhull.so.7.2.0
    
  3. The QGIS should now run with Python Console enabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.