5

Software version: ArcMap 10.5

I am attempting to append data from a Shapefile into an existing SDE Geodatabase feature class using the Append (Data Management) tool. The tool runs, and the results say that it has been successful and no errors are shown, however the point geometry and attributes are not shown in the feature class.

I have tried in both an edit session and not, and using NO_TEST to map the attributes. I cannot see any reason why it wouldn't work.

What am I doing wrong and are there any alternatives to this tool if it is a known bug?

3
  • 2
    Try exporting the shapefile to a File Geodatabase and use the feature class in Append tool
    – BERA
    Mar 31, 2017 at 9:30
  • 1
    Is the target feature class versioned? How are you determining that the data hasn't been added?
    – Vince
    Mar 31, 2017 at 11:08
  • Same as monkeyshines. While working on my office's network drive, while trying to append two features in the same geodatabase, the append populates all records with <null>. At this point I've tried refreshing the gdb and tried removing and adding the feature again to no avail. However, when I work on my local drive, all field are populated correctly. Would be nicer if it worked on our network.
    – JKeeley
    Nov 15, 2018 at 16:21

6 Answers 6

5

Try exporting the shapefile to a File Geodatabase with Feature Class to Feature Class tool and use the feature class in Append tool. When a geoprocessing tool fail with shapefile input it will sometimes work with a feature class input.

3

I was having this issue as well. In my case I was appending points. The tool ran successfully yet the new records did not appear in the target feature class. I refreshed the map and still nothing. I removed the target feature class and added it again then what do you know the appended data was there. ArcMap has a hard time refreshing so refresh your GDB or remove/add your shapefile and the data may be there.

1
  • This was my solution to this same problem. Refresh the database connection and re-add the feature class.
    – CStarbird
    Jun 5, 2019 at 21:06
0

I have also experienced this problem; here is my $0.02.

The cause in my case, as far as I can tell, is that the datasets I was trying to manipulate reside on my local NAS. After testing variables such as projection, field mapping options, et cetera, I copied my input and target datasets to my machine's drive, and lo, it worked.

BTW, the input was a .shp and the target a file GDB feature class. This did not appear to be an issue.

0

Be sure that there are no definition query's enabled on the target.

0

I also ran into this issue, and it turned out that one of the features I was attempting to append had some problem. When I tried to copy/paste-special, I got a message saying I had untrusted html content within one of the fields, which actually had a null value. After I put a value in there, it copied fine. After that record was fixed, all the other features appended no problem.

-3

Make sure that you started an editing session on the layer before running append.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.