2

I am trying to publish my own GP services to a GIS server instance with ArcGIS Server 10.4.1 built on Amazon EC2. In the service editor window, I do not see the "Upload" checkbock that typically shows when publishing GP services on a server. The WPS checkbox is ALSO missing.

Does anyone know why this is happening?

Is this normal?

I want the users of my web app to be able to upload files to use my GP services like I always did for on premise servers.

enter image description here

3

I'm unaware if the Server deployed to Amazon would have different available settings. I'd expect these options should be available.

Try the following at your own risk (as it involves modifying files you shouldnt be touching)

Open the following in a text editor: C:\Program Files (x86)\ArcGIS\Desktop10.5\bin\ServerTypes.dat

Find the heading that starts with:

<ServerObjectType>
        <Name>GPServer</Name>

Before the terminating </ServerObjectType> tag for this section, you should have the following which ensures you can upload and enable WPS while publishing.

<Info>
    <DefaultWebCapabilities></DefaultWebCapabilities>
    <AllWebCapabilities>Uploads</AllWebCapabilities>
</Info>
<ExtensionTypes>
    <ExtensionType>
        <Name>WPSServer</Name>
        <DisplayName>WPS</DisplayName>
        <PROGID>esriGeoprocessing.WPSServer</PROGID>
        <Description>WPS Server Object Extension</Description>
    </ExtensionType>            
</ExtensionTypes>

Note - this file also exists on the server, but I'm pretty sure its the arcmap version you need to modify.

  • thanks so much! I will try these options and let you know what happens...I would think that the settings should not be different either, hence why I was surprised! – Francesco Tonini Mar 31 '17 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.