3

I have created a line. Then, I want to create a polygon from my line. I used the Vector->Geometry Tools->Lines to polygon and a little problem happened (look at the pics, I circled it with a red color):

enter image description here

Why did this happen? I have no line on the polygon where I circled red. I do not want that line on the polygon. I'm using QGIS 2.18.5.

  • @Lassus - SAGA also has a Convert lines to polygons tool which you could try using. You can access it from the Processing Toolbox :) – Joseph Apr 3 '17 at 9:23
  • Welcome to gis.stackexchange! Please edit the title of your question to include enough information for future visitors to be able to find this thread when looking for the same problem. – underdark Apr 3 '17 at 19:00
5

You need to make sure that the lines are snapped correctly. You can set the snapping option from Settings -> Snapping option and select Snap to To vertex and segment, and set the tolerance to 10 pixels.

enter image description here

Then, if the lines are not connected (split), you need to use merge tool enter image description here to merge the lines:

enter image description here

Once it is snapped and merged correctly, you can use Vector->Geometry Tools->Lines to polygon and it will create a polygon correctly.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.